Imp 006 dev board doesn't blink-up

I try to blink-up imp 006 (Murata 1MW, BG96MA) but cannot success - no by WiFi, no by cellular.
Can clear a device settings, bot blink-up stuck.
I try to clear settings and blink again imp C001 and process stop - “Cell Registration Denied.”
So - in case of cellular, maybe something with the provider (LMT, Telia, eSIM), but WiFi is a surprise form me - never had such a situation.
Does imp006 can be blinked-up by WiFi at all?
Any ideas?

P.S. Finally I manage to blink-up by WiFi.

Can you PM with some details? Possibly there’s a SIM issue on that unit.

(update: seems to be power supply related)

I have the same problem, but with two breakout boards at the same time. One imp006 was running for a week and just stopped. I’d tried to make blinkup process, but the board never blinks. I open the second imp006 board, it blinked, it was associated with the platform as expected, and after that it also stop blinking.

I tried to power up using USB interface, also tried to change jumpers and connect with batteries, but both does not wakeup. Other imps just work using the same cable and USB interface.

Any ideas why two imp006 boards stopped in the same day? Is there any way to force imp to wake up? I also tried the wakeup pin, but no board reaction as well.

Exactly how did you have the board powered (like: what USB supply were you using)?

If you are not seeing any LEDs on power up, that’s generally a sign that you’ve fried the board somehow. That’s not easy to do, even if the jumper settings were not right. The LED will ALWAYS come on when you cold boot.

I did as I always did: a USB interface in the computer - pretty sure that the interface runs fine - I test imp002, imp004, imp005, and imp006 - before and after the imp006 fails.

The battery pack was the same: I used to test dozens of imp002 one day after the imp006 fails. No electrical problems - all devices ran as expected.

Something unexpected with imp006: hours before the device fails it was communicating with the electric imp cloud but the device status was offline all the time. I received all communication as expected, but the status offline did not change. after 8h aprox. the device stopped working. Before the failure the imp006 was registering the proper voltage (aprox. 3.35V).

The status in the IDE can be stale, I’ve noticed this too. Usually a page refresh sorts that out (even if you’re getting logging).

But, if there’s no LED on cold boot, something in hardware has died.