IDE stopped working!

Hey, all!

For some reason, upon changing up which Imp runs one of my models, the IDE stopped working altogether for me… :frowning:

Now, no matter what I select in the left-hand menu (be it a model or a device), the code doesn’t show up - the IDE blinks and I just keep seeing the “There is nothing to see yet! Click on a device to start editing!” notice.

I tried to narrow down the cause of this via Firebug and I saw this error thrown each time I try to open a model -

Timestamp: 05/12/2014 11:42:17 PM
Error: MutationObserver is not defined
Source File:
Line: 592

My entire IDE is now blocked… Someone please help!

@Hugo - Please, let me know if I need to provide any additional info in order to get this resolved easier.

Thanks in advance!

Could you please try clearning your cache and refreshing the page. It’s possible something went amiss with caching during an IDE update.

If that doesn’t work, send me a PM with your email address and I’ll follow up.

Hey and thanks for the quick reaction!

Already tried clearing the cache and refreshing, but no joy…

PM sent! Thanks in advance!

I have what may be a similar issue … I built up a basic breadboard kit for a friend. It included an April, an Imp, some LED’s, etc. I connected the device to an Imp connected to my WiFi, so I could rename the device number. I then disconnected it, drove across town with a new unblinked Imp, and went through the commissioning process. We created a new IDE acct. for the new user. We were (finally) able to BlinkUp the IMP (boy, is that finicky!) but the device (the April) simply doesn’t appear in his acct. But when I go to MY acct, there is an unassigned device there (I assume its this new one) that I CAN’T DELETE. Plus, the warning prompt indicates that the device can only be re-attached to MY account after ‘un-deletion’! How do we get the new Imp and the April to appear in the new user’s acct, with a human-friendly name? Different browsers, cache-flush, all tried without success.

Sounds like you blinked up the imp onto your account vs his account? Did you log out of the blinkup app and log in with his account?

A brand new “developer edition” imp would be finicky to blinkup with android as it’s running software that’s almost 2 years old now. Were you using android or iOS?