I just can't get BlinkUp to work


#1

I have read all the FMs and tried BlinkUp on my new (Delivered 21-Sep-2017) impExplorer Developer Kits. I am using an iPhone SE with the latest ElectricIMP software. I get blinking Red lights and then the Imp goes dark. Not connecting to my Wifi device (correct wifi network name, check, correct password, check). I have even done Blink up in the Dark, removed my screen protector, etc. etc. etc I have searched the forums, followed a broken link to a windows BlinkUp-App, and on, and on. Anyway just going through that so you know that I have really been bashing at this from a few different angles before posting.

Thanks.


#2

First, just check you’re using the latest version of the Electric Imp app (it’ll be listed as 4.4.5 in the iTunes app store).

With the imp001 card in the impExplorer, I would lay the phone screen face down on the inserted and powered card. If that’s not catching it for some reason, try holding the impExplorer with the exposed edge of the card (you’ll see it has a little window) up against the phone screen while keeping your thumb over the face of the card. Always do BlinkUp when the imp is flashing; if it’s gone dark, just power-cycle it.

Are you seeing orange as well as red? If so then that’s a sign the imp can’t connect to your network: WiFi could be operating in the 5GHz band, which the imp001 doesn’t support, or on channels 12 or 13, which US imps can’t use for regulatory reasons.


#3

Right, well I am running Electric Imp version 4.4.5. I had previously watched videos and read instructions on holding the screen to the IMP’s ‘window’ on top. I have tried that, on my desk, under my desk, with a towel thrown over my hands … No Go. The Imp goes green for a second and then goes immediately back to long red two short red blinks, and then goes dark again.

I am certain the Network I am connecting to is 2.4Ghz since I have a separate Network name for the 5ghz. As for channels 12 or 13, I have no idea. I am in Australia, so you are saying that Imps are US only devices? That seems super strange to me… just sayin’…


#4

They’re not US only, but WiFi channels 12 and 13 are not available for use in the US, so kit intended to be sold in the US, and that includes some imp001 cards, must not access those channels. We have imp001s that are set for ‘rest of world’ which can access those channels, but I suspect the impExplorer kit ones are targeted at US users. All you have to do is set your WiFi router to use a specific channel, from 1 to 11. That usually means disabling modern routers’ automatic channel selection. I’m in the UK and I got bitten by this some years back.

In fact, checking the BlinkUp LED codes page reveals that long red, short red, short red is the signal for ‘searching for WiFi’, so I’d bet your issue is the WiFi channel.

The green light you mention indicates that BlinkUp was successful - ie. the data was correctly received by the impExplorer from the phone, but the impExplorer is then having difficulty connecting.


#5

If you want to find out what channel your Wifi AP is using, there are a couple of options:

  1. Access the admin page of your AP and find out. Obviously, this depends on what AP you’re using. Consult the manual (hah!).
  2. If you’ve got an Android device, I recommend Wifi Analyzer.
  3. If you’ve got a Mac, I’ve heard good things about WiFi Explorer; I must play with it myself at some point (but I’ve not needed to; see above).
  4. Unfortunately, I believe that iOS doesn’t allow this level of access to the Wifi chipset, so there are no equivalent apps for iPhone/iPad.

#6

OK, thanks the help Smitty and Roger, I have the imp up now. You were right it must have been the channel. I manually set my mobile WiFi Router to Channel 9 on 2.4Mhz and that did the trick. It was set to ‘Auto’ so must have been slipping all the way down to 12 and 13. It is a Netgear Nighthawk M1.

All good. This is solved. Thanks again :grinning: