Hello World example

I’m trying the hello world example (http://devwiki.electricimp.com/doku.php?id=helloworld). Ubuntu host, with Chrome an
Firefox. Also tried Mac, using Safari and Firefox. I edited my code, followed the example up to the point where
I’m told to load the code. Screenshot attached. I can’t quite seem to convince the system it needs to
load the firmware. Also, in the code window, the directions mention in passing that there is a run
button - I see this flash briefly, but it disappears when the editor starts. I’m starting to wonder whether
this is a browser issue. Imp Developers: what is your Q/A & dev platform here - are you guys using
Internet Explorer or Safari/Chrome/Firefox?

I have 5 Imps here that I would like to use. First experience with the Cloud tool has been, frankly, a
disappointment. I would much rather use a tool I can run from my machine here, eg Eclipse
based or even something simple like Arduino Sketch.

In any event, I’m hoping this is just my blindspot versus a browser implementation type issue!

Solved one of the problems, with getting code to run. I found a note from
another Imp user (http://forums.electricimp.com/discussion/548#Item_3) that suggested
that the first code clip created doesn’t work. I just copied the Hello World code to a second
clip, and sure enough, I was about to download & run the code.

The remaining mystery is where the Run/etc buttons go when the Code editor starts.

Imp Devs - just a friendly suggestion. First impressions matter, so perhaps that Hello
World example might be an issue worth getting to 100% on?

You need to click the edit link from the blue imp node to get the Play/Run button and see the log output from that particular imp/impee combination. If you go through the code menu it allows you to edit and save the code but it won’t run on the devices until you physically reseat the card or the imp is otherwise reset.

The IDE is due to be replaced really fairly soon by the new one, which is a lot more sensible and works like you’d expect. However, this also means that all our “getting started” pages need to be rewritten.

Sorry that you fell down a hole with respect to initial setup!

Thank you for the post and answer. I was completely stuck here too. Had to make multiple programs, then click settings and edit 3 times, on the 3rd time the program actually loaded.

Thanks for this, I was just getting a not found message when clicking on the edit and it wasnt uploading the code. Soon as I added a another entry on the code tab it started working.

Now on to the play :wink:

Thanks for this; I just had to “copy” the program from the “code” screen, went back to the planner, selected it, got an edit link on the Imp (which had not appeared before), clicked edit, then the “run” icon was enabled at the top of the code editor, clicked it, and it ran! The output appeared in the editor’s log window, and also on the imp image in the planner.

Early adopters are developers and hackers so won’t mind bugs when there are workarounds like this. But it’s really a shame not to patch the “Hello, World” wiki page to let us know how to do this in the interim. Why on earth not?


Thankyou DAn. Solved my problem.

I have to agree that it would be better that the first experience of “Hello World!” worked! I had to say I was asking myself “Why can’t I get this to work?”. Glad I found this thread.