Grove i2cJH on impC001


#1

I am unable to initialize the I2C grove connector on the new impC001. Would anyone point out what’s wrong? This page says to use the hardware.i2cJH for the grove connector. https://developer.electricimp.com/hardware/resources/reference-designs/impc001breakout

My code:
// Configuration code for Grove I2C port on impC001
i2c <- hardware.i2cJH;
// Configure clock speed
i2c.configure(CLOCK_SPEED_400_KHZ);

Server Log:
2018-09-17 12:49:58 -04:00 [Device] ERROR: the index ‘i2cJH’ does not exist


#2

i2cJH is correct, but it wasn’t enabled in impOS in some early releases of the firmware. I’ll contact you directly to make sure you’re on the latest pre-release.


#3

This is because currently, cellular is not on the full release (even number) - it’s on a dev release (odd number, ie 39.x) and hence has a moving target to upgrade to.

It should now upgrade to 39.12 and be happy. Let me know if it doesn’t.