Fighting some flaky behaviors

Curious what you guys will make of some of the behaviors I’ve been seeing. I have a second imp that I need to try to see if the behavior follows or not:

1) Doing the Blink Up takes a dozen or so tries.  I’ve done it in a dark room, I’ve shielded with my fingers, I’ve held the phone directly against the windows, I’ve held the phone a short distances, and every combo in between. Same issue of lots of attempts. 

2) Using a Verizon MiFi hotspot the Imp seems to lose it’s wi-fi connection and go to sleep/stop blinking.  Have to unplug it a number of times to get it to reconnect.  Also has been struggling to reach the cloud lately.  Didn’t have this issue on my home wi-fi (can’t use work wi-fi for security reasons). 

3) I lose my Imp in the impees section on all the time, probably because of #2

I’m still working through my understanding of the coding interface which has its own struggles for me, but that’s more my familiarity and ability than anything. 



Well - there are definitely issues with the Blink-up process with certain phones. Head over here and see if your phone is listed in the yay or nay section.

Regarding the MiFi - which one do you have? I have the 4510 and had many connectivity issues in general prior to updating to the latest firmware, which is 2.28 I believe. Prior to the 4510, I had the Samsung piece, whichever it was - I couldn’t hold a connection to save my life, and eventually returned it to get the Novatel piece. How long are you having the imps sleep for? Is the amount of time longer than your idle disconnect setting in the MiFi? (I’ve disabled mine, FYI.)

We’re shortly going to be rolling out the keepalive code, but until then, if your imp isn’t transmitting regularly it could be getting caught by a NAT timeout.

Something like this will help a lot:

function keepalive() {
imp.wakeup(30.0, keepalive);


…to ensure there’s traffic every now and then.