Env Tail - i2c error -2: TRANSMIT_SELECT_ERROR

I picked up a Tails Kit at Maker Faire Bay Area, and finally found some time to have a play. After a little difficulty getting it up and running (failed BlinkUp first attempt, IDE not working until I’d registered the Imp), I tried to get the Env Tail (rev 2 20141111) up and running, using the sample projects as a guide. I haven’t been able to get either the temp/humidity or the pressure sensor to work - both give an i2c -2 error (TRANSMIT_SELECT_ERROR), and the pressure sensor (LPS25H) additionally gives this trace:
2015-07-04 20:09:32 UTC+12 [Device] ERROR: I2C read error: -2
2015-07-04 20:09:32 UTC+12 [Device] ERROR: the index ‘0’ does not exist
2015-07-04 20:09:32 UTC+12 [Device] ERROR: at enable:87
2015-07-04 20:09:32 UTC+12 [Device] ERROR: from init:47
2015-07-04 20:09:32 UTC+12 [Device] ERROR: from constructor:42
2015-07-04 20:09:32 UTC+12 [Device] ERROR: from main:11

I haven’t yet dug out my logic analyser to see what’s actually going between the April and the Env Tail, but has anybody experienced similar issues and got any suggestions?

Sounds like either a connection issue or the I2C bus is stuck? A logic analyzer will definitely show that but if you have problems we can swap the board out for another one.

Does the neopixel tail work ok?

The Neopixel tail works fine. I still haven’t had a chance to dig out the logic analyser, but I’ll report back when I do.

I’m experiencing the same exact issue with my env tail. My neopixel tail also works fine. Just wondering if pauln had come up with a solution or determined if the env tail was defective. I noticed a few dry solder joints on mine, I touched them up but still no dice and the same error messages as pauln above.

If you contact info@electricimp.com we can sort out a replacement for you.

Thank you Hugo.