Eimp fails to read Blinkup data

I tried several times now to commission the eimp. I use a Sparkfun Shield and the eimp starts blinking orange when powered up. I start the android app, enter my wifi credentials and start the blinkup. The eimp stops blinking until the flashing of the app is competed, then goes binking red in a fast manner. I read this as indication, that the blinkup information is not understood. After a few seconds, the eimp binks orange again. Ambient light is not an issue, I tried it in a dark room as well.
After a while, the eimp goes off and does not come up again, even after re-inserting into the slot on the shield. Only power-off on the shield resets the eimp.
Looks DOA to me…
Any help is welcome. Also some protocol feedback to the app would be a good idea as blinking led is not the best human communication channel ;^)
Ciao, Mathias
impee: sparkfun shield on arduino mega, android 4.1.1 on Galaxy Nexus

As I continued to test this multiple times, I got the idea to rotate the phone by 90 degrees. Nothing else was changed but this time, the device accepted the data, went green/orange, then red/roange and is now green.
This seems to be quite strange … Anyway - if you experiance the same error, try rotating your phone (a polarisation effect?)

Hmm, never heard that one before! The contrast ratio of an LCD is dependent on viewing angle so that’s probably it - there’s no polarizing filter on the phototransistor.