Downloading new code and disconnect

I seem to be having an issue in my (newer) account that has privs to promote to ops. I have no idea if this account is different, although I seem to recall having “new” experiences with this account as compared to my initial dev account. I’ve started moving all my devices to this account due to BlinkUp issues with the old (ctmorrisonhvacsp) account.

I have several devices in this account and they seem to run fine. However, I have tried repeatedly to move a device from one model to another and I get:

date timestamp [Status] Downloading new code; 16.91% program storage used
date timestamp [Status] Device disconnected

The MAC address is: 0c2a6906be80

Note, this model is being used by another device without issue. It almost seems the above imp simply stops talking to the agent when I try to move it to the new model.

(update) False alarm??? The device finally came online, but I don’t understand why model changes under this account seem to be handled differently. Perhaps it’s just my imagination.

Hmm…by now I should know this, but…

The above problem was solved by clicking in the device code window and pressing the “Build and Run” button. It seems this was required in order for the device code to be downloaded.

So…I’ve always assumed (yes, dangerous) that clicking on “Build and Run” would always recompile and download both the agent and device code. Is this a good assumption?

(update) By the way, I really do appreciate everyone’s patience as I post what appear to be simple issues.

Please ramble on, we learn a lot from your blog!

Things shouldn’t be handled differently there, but if you see issues please file a support ticket - the forums are great for general support, but we do have a commercial support channel for the more complex ops issues :slight_smile: