Difficulty with Blinkup/connections

So I got my imp a week or two ago, and managed to get it connected, and played with a few sample programs with it, and all was good. I unplugged it to deal with other things, and today I plugged it back in, expecting it to reconnect and show up in my list of devices. Unfortunately that’s not what happened. After a few minutes of a blinking green light, the imp went dark. No blinks, Doesn’t show up in my list of devices.

So I unplugged it, plugged it back in and cleared the device settings. Then re-blinked it. Seems to have worked, as I got the flashing green light and then … it went dark again and still doesn’t show up in my configured devices.

So what am I missing here?

The BlinkUp LED will go off after 60s unless you enable it, but that doesn’t explain it not showing up.

Is it not listed under the model that you last assigned to it?

Nothing listed at all. The first time I provisioned this device I must have gone through the blink-up procedure a dozen times before it finally showed up. I was just hoping not to have to do that every time I power it on to work with.

And suddenly it showed up!

Remember it’s NOT the imp card that shows up in the IDE, it’s the device it’s plugged into. Imp cards on the same account are totally interchangeable.

eg if you have one imp and one april, the april appears in the ide. If you buy another imp and plug it into that same april, nothing new will appear (the new imp will just run the code you’d assigned to the april).

I am having trouble getting my device to show up on the server. I can configure the Imp on the wireless network. I can see it from my wireless router. I also made sure the port is open on the router. The blink codes on the Imp looks like it is downloading. It has two green blinks with dark pause then loops again. I can’t see anything online that shows a device.

What are my next steps to try?
thank you

If it helps. April Card is Rev3 20121016

Imp card

Need to know the mac address of the card; the other codes are just generic approvals so don’t help me when looking in the logs.