"Device Data Retrieval Error" When Registering imp001 Developer Edition


I have a problem registering my imp001 developer edition to the Electric Imp server. The BlinkUp was successful, the imp001 was able to connect to the Wi-Fi network. After the BlinkUp, I got the green LED slowly flashing (https://electricimp.com/docs/troubleshooting/blinkup/serverconnected/). However, the Electric Imp mobile app threw an error: “Device Data Retrieval Error” and there was no device on the IDE.

Screenshot: http://imgur.com/uJgGntU

The MAC addresses of the imp001s are:

I have tried to use BlinkUp with different phones (iPhone, iPad, and Android with/without legacy BlinkUp mode) and different Wi-Fi networks but they gave the same error. Let me know if anyone also has this issue. Thanks.

Kind Regards,

Looks a bit like these imps were inserted into blessed devices - ie ones which someone else has locked to their account. You won’t be able to blink them up to another developer account because of this.

Got a standard developer board to plug them info? The developer of the device they are plugged into can also remove the blessing.