Desperate need help with blinkup


#1

So recently I brought this imp001, not sure if it is dev edition. I used it with an Sparkfun Arduino shield. Every time I put the chip in, it flashed in a pattern I did not recognize: long red, long red, long red, long red, short red, short red, and repeat. ANd every time I tried to blinkup, it always went through the entire logo (in IOS app) and said device not connected at the end. I desperately need this to work and I found no useful information on the web. Thanks for any useful reply!


#2

The IMP will give a short green flash as soon as Blinkup finishes, but you have to be quick to see it. I think the quick green flash was made longer but you still need to be quick.

If you don’t see the flash then try blinkup in a very dark environment, you’re looking for that quick green flash as soon as blinkup finished.

Check wifi range at IMP location.

If Blinkup (quick green flash) has worked but still no wifi, then double and triple check the wifi credentials zeros and ohhs, ones and els, that kind of thing.

If the credentials are good, check the acess-point isn’t operating on channels 12 or 13. The USA version of anything wifi including domestic IMPs aren’t permitted to use these channels but outside of the USA about a third of all AP’s are using channel 13.

Using the above steps has solved my blinkup troubles everytime, Hope it helps you.

David.


#3

Also note that the LED on the imp should remain blank while BlinkUp is happening. If the LED flashes before BlinkUp has finished, it failed.

Your imp001 is likely to be running a relatively old version of impOS, which means that BlinkUp can be a bit sensitive to ambient light levels. Newer impOS versions are much improved, but you need to succeed at least once to get the new version.

As David says, try a darkened room, or find some other way to remove ambient light. I particularly struggle with this because my desk is a massive slab of white, so I sometimes resort to holding the phone and imp inside the (black) sleeve for my tablet.


#4

I’m assuming you are using the Arduino shield like this?

David and Roger have good advice … do the blinkup in a darkened room, especially a room without sunlight. Not necessarily totally dark, but dim. Another thing to try. Remove power from the Imp for a bit, when you power it back up, do the blinkup 15 seconds after you apply power. Do it within the first 60 seconds. I’ve had this issue before with older development imps.


#5

Thank you everyone! I think I got it to work!!!