Dead Imps? (strange problem)

Howdy y’all

I have three imps (well… more than that but these are important in this case).

Imp 1 connects to wlan. I can re-blink it up and it connects ok again.

Imp 2: I insert it to the same april-board and blink it up with the same phone and same settings: does not connect.
Imp 3: Same as Imp 2.

After blinking up Imp 2 or Imp 3, they try to connect to wlan:

They both do blink message led for “Searching WiFi network” once, “getting IP address” sequence for a while and then stop blinking.

If I insert Imp 1 to that same april-board, it connects ok.

I have tested this with three different April-boards. Same result: 1 works ok, 2&3 do not.
Just for fun I tested this with three different Wlan APs, with and without encryption. Same result.

Question: what could have killed my Imps (2&3) or are they dead at all and how do I get them working again?
Obviously they are not completely dead.

They used to work just fine some time ago. They have been just sitting in ESD-protected box since then and now when I tried to use them, they refuse to work.

MACs of Imp 2&3:


Now this gets interesting.
I just left those two nonworking imps at the table and the next day when I powered them up, everything worked.

I noticed the imp-slot in april-card is quite loose.
What I mean is that even when imp is inserted to slot, it moves a little bit.

Could some kind of connection problem cause this behaviour?
Unlikely though because I swapped imps between aprils when trying to get them working.

There have been April board problems in the past, specifically related to pin 1 not working. You might have another defect issue. Where did you buy them from, and did you buy them at the same time?