Constant Red/Amber Flashing

I’m having some trouble with my imp001 from Sparkfun. I bought the card from Sparkfun along with their breakout board and everything seemed to be fine. I was able to blinkup and connect to my wifi, then program a simple ‘hello world’ LED flash. Then I put the imp away and came back a week later and when I plugged it in it will only flash it’s red/amber LED forever. I can’t blinkup anymore (either to change the wifi settings or clear them). The red light just continues blinking throughout the blinkup process. I’ve tried doing it in a dark room, covering the top with my finger, different distances away from the card, nothing works; just a red flashing light the whole time. I’ve used two different iPhones (which I read are more reliable for blinkup) and gotten the same result.

Here is a video of what it looks like: As you can see there is a quick yellow/amber flash then the red light, then it turns off and repeats.

I read a few people who were having problems with the security settings on their wifi, so I tried every combination of AES/TKIP, WPA2/WPA/WEP, WPS, no security, everything. Nothing changed the red flashing light.

I’ve pretty much given up hope at this point. I’ve checked both battery voltage (4V from a 3.7V Li-Ion) and the regulator voltage (3.3V steady). If anyone has any suggestions at all I’m open to anything. As I said it was working fine a week ago. My only thought is that maybe it was in the middle of updating firmware when I unplugged it and that has bricked it?


What channel is your access point using? Are you using a US imp001 outside of the US? A common issue is the US imps not being able to see channels 12-13.

No, this is inside the US. So I can’t set the router above channel 11.

Do you have a lab power supply at 3.3V that you can power it with? I once had an odd led blink pattern and I eventually figured out the imp was a bit starved for current at start-up.

If your imp doesn’t stop blinking during BlinkUp, there is likely either a power or hardware issue. Send your Device ID to They can take a look at the logs and probably see what happened.

I had a lot of offline imps offline (although appearing online) for most of the day already. Guess it has something to do with the server maintenance ongoing

Thanks for the comments guys! I will definitely try sending my info to the support people and see what they have to say.

I’m using the SMPS that is provided on the breakout board (just a clone of the April board) with a 1000mAh Li-Ion battery, so I don’t know why there would be a lack of power. I haven’t checked current draw on it though, so maybe I’ll have to do that.

I agree that it is probably something hardware related, so I was hoping someone would be able to decode the red flashing as a known problem. I guess I’ll see what the support people say and cross my fingers that it’s an easy fix. I’ll post back here if I do find a solution.

Thanks again!

This looks very much like the imp is browning out; . Have you tried USB power instead?

The imp can deal with losing power during a firmware update, it will recover and restart the update. It shouldn’t be possible to brick a device like that.

I just got home and gave the USB power a try and voila, it works! So I did a bit more testing under the assumption that it is browning out.

I tried adding a 1uF ceramic capacitor near the board and powering it from the battery; it had the same problem. Then I added a 100uF electrolytic and I was still having problems. What I eventually figured out was that it was the distance from the battery to the imp that was causing the problem. I had the whole thing breadboarded and the imp was on the upper part of one side of the board and the battery was plugged into the upper part of the opposite rail section. So the current had to go down one rail across two jumpers and back up the opposite rail, then the same path to return. Seems stupid now that I think about it, but hindsight is 20/20 after all.

So for anyone reading this in the future, if you see a quick flash of amber/red then off then back on again, it is most likely a brownout. Make sure to check that the voltage drop at peak current is not dipping below the voltage required to drive the SMPS/imp.

Thanks for all your help guys!

Breadboards are notoriously bad for demanding power users - the resistance and inductance can be a killer, even with big caps right next to the consumer.

Glad it’s all happy now!