Commissioning issue Android and iOS


I’ve received my new imp and breakout in the mail today and am unsuccessful in commissioning it.
I’ve tried the android app on a Samsung Galaxy Note 2 and the iOS app on an iPhone 4.

With both I get the same behavior: a brief green blink at the end of BlinkUp, then the imp settles into a 3 slow green flash, 11 fast red flash pattern. I don’t see that pattern in the ledcodes page. Is it “Connection lost, attempting to reconnect”?

At first I thought this may be an android problem. But I am getting the same thing using the iOS device.
With both I am able to clear the wireless configuration with the app and return to the slow orange blink.

Did I get a hardware dud?

I commissioned an imp on this same network two months ago using an iphone 4s with little difficulty. Perusing the forums I see some talk of a half-speed android blink-up, which I could try. But the iphone at least should have worked…

Many thanks for any troubleshooting tips,


Try this just for the heck of it.
Remove power from the imp. leave the power off.
Get your phone ready to blink … enter ID, Pass and get ready.
Power on the imp, wait one second, then blink it.
I had similar trouble and discovered if I let the imp sit powered up too long before blinking, it would not accept the blink-up. Doing the blink-up right away seemed to work.

I supposed it’s just ‘witchcraft’ and I am imagining it, but I repeated the same thing and it worked the same way. Ambient light is another possibility. Not so much an issue if you have the imp in an April board because the sides are covered.

Slow green, fast red generally indicates a couple of things, beyond that your imp is connecting successfully to wifi and from there to the server:

  1. The squirrel being loaded (associated with that board) has a runtime error. The code runs, crashes (flashing red), then the imp connects again, loads the squirrel, which crashes, etc etc. To fix, go in and fix the code (or just make it say “imp.configure(“test”,[],[]);” so there’s nothing there to cause an issue).


  1. The ATSHA chip on the board is broken in some way, which means the imp has no idea what it’s in and the server will reject the connections.

If you can tell me your mac address I can see if it’s (2). We’re working on a way to indicate this scenario to a developer…

Thanks for the response.

  1. I haven’t uploaded anything to the imp and it never showed up in my planner. Does that suggest I’m dealing with 2?

I’ll double check tomorrow and send the MAC address.

Thanks for the reply,


The MAC on my imp is: 0c2a960008f1.

The imp has never shown up on my planner. I tried to blinkup once more and am still getting the slow green fast red.

Thanks for your input…


Checked the logs and it is (2) - your ID chip is broken in some way I’m afraid. Who did you get the breakout board from? Has it ever seen any high voltage?

I purchased it from Sparkfun, and simply soldered on the power select jumper and plugged it into a usb port.

Are you saying the breakout board (with ID chip) is now defective, or the imp itself?

The breakout board seems defective. The imp seems fine, as it’s connecting to the server.

…could also be a bad socket or bad soldering on the ID chip. Worth looking closely to see if it’s an easy soldering fix.