Commissioning doesn't work at all

I got my Imp and have tried to commission it with a breakout board from sparkfunk without success. I’ve tried it with a HTC One X with at least three networks. Needless to say, I checked and tested the passwords thoroughly and even put black tape on the top of the Imp. I even tried to change the distance of the screen. Once the Blinkup finishes, the led blinks slow and red, i.e. it tries to connect to the network but then it goes orange. Any ideas why?

blinkup is really finicky.

  • reboot the device just before trying.
  • turn up screen brightness all the way (turn off automatic control)
  • try different locations on the screen - I don’t think holding it further away will help. I feel like I have had more luck near the screen edges but it doesn’t make sense; I’ve got no explanation for it.

otherwise: use the Windows blink-up or as the imp guys for the slow Android one - or borrow an ipod.

I wish the guys would put these things in the known issues or other FAQ

Windows Blinkup? What’s that? Isn’t there a desktop application for the Blinkup?

Ok, working. It’s just updating the firmware. Here’s what I’ve done: I created a WIFI-hub with my Android phone and switched off the authentication (open network). It worked!

Ok, can i please get the slow version maybe? i have the sparkfun breakout board aswell, i have connected the imp using mini-usb (checked voltage with multimeter, says 5.xx V so i guess that’s correct and i haven’t friend my imp :>) and i have the HTC Desire HD (which is not in the list of supported devices so it probably has to do with this…)

“”"“MAYBE”""" it is nice to make a list of devices that are known to need the slow version, so that there is no doubt for those users that they need the slow blink version app…

I have to say, as a starter the startup documentation is really very, very little which makes me sad :frowning:

supermaggel, I think you need to email

to ask for the different software.

On my Android devices I have had the best luck keeping the imp relatively near the edge of the screen rather than out in the middle. I always turn off auto-brightness and of course turn the brightness all the way up.

Hugo and all, I think it would be a good idea to put this information in the Known Issues section - perhaps a link to the improved blink-up app. Causing new users frustration is not… a good thing.

Hi mjkuwp94 (strong crypto username there)

Thanks for the tips, yes i’ve forgot to mention that i’ve tried all of that. I even closed the curtains in my room, tried several positions for the mobile phone and imp, regions on the screen… no avail.

I also forgot to mention that i do NOT see any blinking occurring at all!
Not when just powered, not after ejecting / inserting and not after flashing/blinking, is this a different problem?

I mailed to the email adress you gave, thanks!


ALL documentation could be improved, but in the end, everybody gets his Imp commissioned…
Why should we as users, not start writing simple user documentation?

@supermaggel: if you’re not seeing the LED on the imp ever light up, then that’s a different problem!

Are you using a sparkfun board? You need to solder a header/link onto these if you’re powering via USB, because they didn’t fit it. See the note on our devwiki:

@hugo thanks for that, i thought something like that was missing.

I got it working now, add HTC Desire HD to the list of working android devices (with current BlinkUp version). you do really have to keep your fingers on the top and bottom of the imp to shield it from leaking light for it to work, even in dark.