Cant clear device

Hello,
Im hoping folks are still using these devices? and looking thru this discussion board, some posts are several years back.
I dug up some older imp001 boards to restart a project. One of them is able to clear settings and take a new wifi connections. The other is constantly blinking red and Im unable to use the smartphone blink app to clear its settings, or set new wifi settings.
Is there a work around ? Could this one imp be locked?
I’m getting 5 red light blinks and then 1 quick red light blink. Repeats.
Any help is greatly appreciated, please.
Thank you in advance.

//-Joe

What type of phone are you using for the clear? Depending on how old the device is, it could be running a very early version of software which may not be super happy with android blinkup (especially if it was pre 2014).

I can look up the OS version the device was last seen with if you can give me the mac address.

Thank you so much for the prompt reply! Im using a Samsung Note 10. As I said, it worked fine on the 1st imp001, but perhaps this one is on the edge. I could try an older Samsung S3.
In the meantime its mac: 0c2a690039c3

0c2a690039c3 is so old that it’s not even in the database (so possibly has not connected since 2012/2013).

You will need to enable “legacy mode” in the android blinkup app to have any chance at all - or use an iOS device to get it online so it can update. After that point, android blinkup will be fine again.

Solved! Houston…2 Imps safely on board. It took an iphone X to factory reset it and set the wifi (had to use a network with no password at first). Then tried the android note 10 in legacy mode and it worked as well.
Thank you for the help !
//-Joe

Wow yes, that device was running impOS release 8, from Oct 11, 2012 before it auto-upgraded. That’s… quite old!

imp001 still supported though, and getting the latest release 42 shortly :slight_smile:

Well, if anyone wanted a “software use case” where it tests if a really old version can be updated in the field…there you go ! :wink:

We do have automated tests for this, but always nice to see it working in practice :slight_smile: