Cannot connect to WiFi - imp001


#1

Hello! I am trying to configure the Electric Imp (imp001 card and development board) but seems like it cannot connect to WiFi. The app says ‘Device did not connect’ and the LED is flashing like ‘Searching for WiFi network’.

I changed the WiFi channel from 13 to 5 and it’s 2.4GHz. The network name and password should be correct and I’m not sure what is the problem. Is there anything else I should check?

Thanks in advance!


#2

You must not be in the U.S? as you mentioned channel 13.
Describe your blink-up process, the smartphone, device, etc.
The lighting of the room when you blinkup, how you hold the phone, etc.
After the blinkup, describe the LED colors and flashes.


#3

Yeah I’m not in the US. I used iPhone 6 and tried several places in the house, normal light, dark room etc. I tried both laying down my phone to the device and holding the imp against the phone (and keeping the top side covered).
After the blinkup, the LED flashed green for a short time, and long red flash followed by two short red flashes. I could clear the device setting (it flashed orange after) so I am wondering if this is the wifi issue :confused:


#4

As per the BlinkUp Troubleshooting Guide in the Dev Center, the green flash is the indication that BlinkUp was successful. The long red and two short red flashes suggests that you’ve entered your WiFi network name incorrectly, or there’s a channel and/or WiFi band (2.4GHz vs 5GHz) issue — this pattern indicates a problem finding the network. A long red and three short red flashes, BTW, indicates the imp has found the network but can’t log on (ie. a mis-typed password). You don’t have to enter the security type; the imp figures this out for you.

You should note that WiFi routers which expect you to connect to WiFi via a web page are not supported.


#5

Hmmm okay, the device worked with the wifi in the office so something is wrong with my home wifi :frowning: I will keep digging the doc. Thanks for your help!