Cannot connect to cloud service (red/orange led blinks forever)


Just got my imp with sparkfun breakout board. Successfully blinked my wifi settings. Then the red/orange led starts to blink forever and the card is not shown in the planner.

Do you have some problems with the cloud servers or it’s something else?


Service hasn’t had any outages; can you give me a bit more detail on the problem?

  • Wifi router and encryption type? (and channel; note that all imps right now are US, so only work on channels 1-11)
  • Is it blinking off, red, yellow (means it’s trying to DHCP) or off, yellow, red (means it’s associated and DHCP’ed but is trying to get to the server)

Have you also tried retyping your SSID and password in Blinkup? A mistyped password - yes, there’s no “show password” option - will look just like this.

It is listed on the network and has a proper IP address (see attached screenshot), so it’s not password or DHCP. And it’s blinking off-yellow-red with 1Hz frequency.

Do have any restrictions on out bound ports?
The imp uses 31314 is that open?

I’ve checked - the port is open. Still doesn’t work.

Ok, so off-yellow-red is consistent with what you’re seeing in terms of DHCP. Sounds like there’s a DNS or connectivity issue.

Do you have any problem going to ? That’s the address that the imps connect to. What router do you have? We’ve had reports of the AT&T 2wire DSL/wifi box being touchy with DNS if you restart the card too often. opens. I have the Netgear CG814WGv2, the provider is Time Warner Cable.

I’ll check the card with another hotspot today and report what happens.

The same behavior with a another hotspot (probably, Linksys), but now it goes off in about a minute.

So, no more ideas about this case?

If so, should I return the card to sparkfun or maybe send it to you for investigation?

Hey mym - We’re working on this. Hang in there. Thanks for your patience.

I can report the same issue with 4 Sparkfun imps. Red/Orange blink for about 1 minute, than it goes off. I’ve got another official imp from the developer program and that works fine

@mym and @haraldini - If you haven’t already, please see If still no success, please contact Thanks.

There seems to be something wifi related. I was successfully running imps on my wifi network, but commissioning did not work. I used my phone as an access point and the imp commissioned on the first attempt. After that I blinked up the other wifi credentials to the imp and they work again on the regular wifi.

This is most often a mistyped password or SSID; everything is case-sensitive, for example. When you re-blinkup it re-commissions, there’s no “saved state” from before.

I experienced a similiar problem while trying to setup several imps (initial attempt): a connection wasn’t possible – tried to connect to a fritzbox-router secured by a wpa2-key (blinking code red/orange). checked SSID and pass, reblinked, still no luck.
the workaround for me was to connect to an open network without wep or wpa – after that, the connection to my wpa2 network worked right away.

@iamnifty : thanks, that fixed my problem. Slow green blinking and showing up in the planner.

I have a fritzbox, the imp would blink off-red-orange and not appear in the list of devices on the fritzbox. I built my own impee from scratch and used an old android phone not on the whitelist so lots of things could go wrong there. I’m glad it was this simple.

Hmm… i cannot get it to connect in WPA mode on the Fritz!Box 7170. Any other tips ?

I am also having problems with commissioning my IMP as well, I got mine from sparkfun and its doing the same thing as @haraldini, it blinks like red/yellow for about a min and then goes dark for the remainder of the time. I am using a apple airport router, with the april board.

@ivoknutsel: can you give more detail as to what the exact settings are? WPA1 or WPA2? TKIP or AES?

WPA (TKIP) won’t work, blinks off-red-orange for a short while, then stops.
WPA2-PSK (AES-CCMP) won’t work, keeps blinking orange.

Is there some sort of minimum length for a password ? I’m getting the impression blink app cant send the right data.