C001 doesn't connect anymore

The C001 breakout board works fine. The sudden imp disconnected and don’t connect anymore.
BlinkUp again doesn’t help.
Status LED just blinking red-orange.
LTE (Telia) network is okay, according to iPhone.
Any ideas? Don’t want to believe that imp is gone…

PM with your device ID and we’ll look?

Thanks, Hugo!
Now it works again!

Errr, I hadn’t actually got to looking at your device, as the ID only arrived last night! I’ll see if the black box had anything in it when it came back online though.

I can see you’re connected on 2G, not LTE; this requires higher current supply. I can see indications that maybe you have power issues (modem dropping off USB) - do you have a battery attached to the board, or just the USB supply?

I have powered it from “traditional” 230Vmain to 5V power supply, 2A is a nominal current.
Besides - I try different power supplies.
Why it is connected to 2G - I don’t know.

I use the following lines of code and I still get server.log:
local cellData = split(cellinfo, “,”);
local ACT = cellData[0];
if (ACT == “4G”) {
local rssi = "4G; " + cellData[12];
sendData.rssi <- rssi; // to send RSSI un simple webpage
server.log("Reference Signal Received Power: " + cellData[12]);

It was on LTE at 2019-12-04 09:25:17Z, but went back to 2G afterwards.

When it’s on 2G, having a battery present is recommended with the breakout.

…that’s for an imp006 though; the same approach isn’t possible with the impC001 breakout.