"Build and Run" greyed out


#1

I’ve noticed recently that I can only click on “Build and Run” once. After that it is greyed out and the mouse changes to a prohibited icon when I pass over it. I have to reload the IDE to be able to make changes to the code. What am I doing wrong?

In this case, I have a device linked to a model but I am working on the agent code and the device is offline.

EDIT: I just tried it with a different model where the device is online and the same thing happened.


#2

Hi dheadrick,

We’re trying to reproduce this issue and can you give us more information -

  1. If you try to wait for the “Build & Run” button to be enabled again, how long does it take you?
  2. You mentioned you used “Build & Run” at the Device, have you tried to “Build” on a Model?

Thanks,
Kenny


#3

I just timed it and it still hasn’t “un-greyed” after 6 minutes waiting. I have tried build on the model and it does the same thing. I have no device code at all… only agent code.


#4

I have experienced this too. I refresh browser, build and run, then it is disabled. It seems to stay disabled, but I haven’t waited for more than a few minutes. If I reload ide, then make a code change and try to build and run, but there was an error, I can edit and upload, but then after I have to reload ide.


#5

Yes… I get this too. If my code has an error, I can “build and run” again immediately. Only if it is successful does it become disabled.

The annoying part is that I continually get warnings that a newer version is available and that my draft code is not based on the latest build.

I’m using firefox as a browser (and always have been).


#6

Do you recall when you start seeing this behavior?

We suspect this is due to slow Internet traffic on your end, do you mind capture the network traffic and send the HAR to kenny@electricimp.com?


#7

I only noticed it yesterday because I associated a device with the model. Until I did that, I wasn’t able to “build and run” because there was no imp present. I haven’t had to make any changes to my other model in months so I can’t really track down when the problem might have started.

I am getting the problem on multiple computers from multiple locations (work and home), so I’m doubting that it is a network traffic issue. How would I go about capturing the network traffic?

(Both computers are using firefox and one is Windows 10 and the other is Windows 7)


#8

What browser you’re using?

We are still working on it and we believe this only happens in Firefox, if you have other browsers installed, can you please switch to them as an interim? Please let us know though if it also happens with other browsers.


#9

Here at work, I am using Firefox 48.0.2.

I just tried Internet Explorer and the issue does not happen.


#10

Thanks for checking @dheadrick

We’re working on a fix now and we’ll post update on this thread when it’s released.


#11

I get this error in the console for firefox (as soon as the code changes). Chrome is fine.


#12

I noticed also in Firefox that after I hit “build and run” I don’t get the green popup which says “Your code has been saved”.


#13

We just released the bug fix and you should no longer experience this issue with Firefox.

The green popup “Your code has been saved” was not displaying was because of the same bug.

Thanks for your help.


#14

Awesome… works great again. Thanks!