Budweiser V1 Goal Light won't connect to my WiFi

I have tried a number of different things to get the light to work:

  • removed all pod extenders from my network
  • created a dedicated 2.4 GHz Wi-Fi networks separate from the 5 GHz network.
  • I run through the setup process in the app with the Wi-Fi card flashing red
    I am using the latest Budweiser app on my iPhone 13 to connect it with no luck (refresh rate is 60Hz by default). And I moved to a different floor from my modem to attempt the connection.

My Wi-Fi details:
Protocol: Wi-Fi 4 (802.11n)
Security type: WPA2-Personal
Network band: 2.4 GHz
Network channel: 6
Link speed (Receive/Transmit): 144/72 (Mbps)
IPv6 address: 2607:fea8:3a16:a500:b96a:f915:d275:6023
Link-local IPv6 address: fe80::b96a:f915:d275:6023%15
Description: Dell Wireless 1703 802.11b|g|n (2.4GHz)
Driver version: 3.0.2.201
Physical address (MAC): E0-06-E6-A5-0E-55

Any help is appreciated.

Any hints as to what I can do?
if the light is still connected to another device how to I disconnect it?

Hi @vanoirm as imp001’s are getting a bit long in the tooth – it’s entirely possible this is an issue with the imp HW. If you DM me a mailing address I can ship a new one out to you and see if that solves your issue.

That’s great. Will do.