Budweiser redlight wont connect


#1

Hey guys! Pretty new to this imp stuff… I recently got a Budweiser Redlight and i just cant seem to connect it at all… when it say to put my phone on the sensor the redlight stops blinking… then it blinks once… the app tells me ‘‘connecting’’ and then it goes to a oops try again page… every single time… then the wifi light starts blinking red again… rinse and repeat

Heres what i got so far as information to try to get some help?:

-Its the new version of the light so the card is built in.
-I write the good SSID and password i tried with a different device to make sure it wasnt typos or caps
-My router is 2.4GHz
-My app is on an Android Device ( version 6.0.1 )
-Router is on channel 11

Sorry for my rough english but any help would be appreciated :slight_smile: I tried contacting budweiser but it seem they are always closed when i call…

-Kevin


#2

Can you give me the mac address of the device (starts 0c2a69 on the underneath) - I can then see what OS version it has on it.

What android device, and have you got any other devices you can try with?


#3

Sorry for late response i wasnt home for the holidays here it is!
MAC: 0c2a690b4d78

and its a samsung galaxy s5 i also tried with a galaxy s6 and it didnt work… i dont have any apple or ios devices and my tablet is windows and it doesnt have the app.


#4

Should be fine. Do you see solid green right at the end of the blinkup? If not, the blinkup was not received correctly.

It has release 32 on it, which isn’t the latest but is new enough that there shouldn’t be any android blinkup issues. Try turning off power save mode on the samsung toolbar?


#5

No it blinks red when the app starts flashing the red light stops and then blinks red again… never saw a green light! And it is off… ill bring my light to a friend house see if its my router or something…


#6

I have a bud red light…it’s connected…it’s flashing green. I tested it thru the app before the game. The game is on and we’ve scored 2 goals (awesome!) But no action from my red light. What gives?


#7

@Fan you should ask Budweiser. If it’s flashing green and test is working, it’s connected … but Electric Imp aren’t involved in the distribution of goal events, that’s the Budweiser system.


#8

I tested mine at my friends house with his cellphone and its still not working… never saw a green light yet… Budweiser is supose to call me back hope they can figure out whats wrong


#9

I am trying to connect my Samsung Galaxy S7, but after blink app start a gathering device data, shows moving Eletric Imp logo green from left to right and at the end logo change to red color and there is a msg device did not connect. I already turn off Power Saving, configure brightness with no auto checked and on maximum stage. I tried many time unsuccessfully. My router is a Linksys E2500, wifi MAC address 4C:66:41:B7:3D:38. I tryed using another wifi, but I got the same issue. Please, is there anything I can check?


#10

What model is the red light? Does it have an SD card imp? (those are a lot older and if they’ve never been configured, they may be unhappy with your S7 and you’ll need to try an iOS device for the first connection, after which it’ll upgrade)

The main diagnostic step is checking that the device shows a green LED at the end of blinkup. If it does not, then the imp did not receive the credentials.

If you do see a green light, but then it goes back to flashing red, then generally you have a mistyped password, or you have specified an SSID that the light cannot “hear” (eg it’s on 5GHz, or on a channel which is not in the US/Canada range of 1-11).


#11

Hugo, first of all thank you very much, I do appreciate your attention and support. Yes, I have an SD card (see attached). I tried connect without this SD and got the same red screen result (see attached). I will try to test your recommendations (iOS and on last paragraph) this weekend.


#12

@AHLMattos,

The Imp uses the SD card socket because it’s an easy, readily available piece of hardware. That was part of the initial Imp001 design. That socket on the April board is ONLY for an Imp001.

Hopefully the April board is still OK. You should try to find a friend with an ipad mini or iphone and try the blinkup app with those devices. You can also bring your bud light to someone else’s house and blink it up on their WiFi. That will get it working and updated with the new firmware. Then bring it back home, erase the WiFi settings and blink it up at your house.


#13

Thank you mlseim as well. Unfortunately, I tried with iphone 5c and got the same bad result using same wifi at home (Linksys E2500). I will try in another place during weekend and I will come back with result. It is a very strange issue.


#14

Sounds like there are a couple of different conversations going on here.

@ahlmattos: are you trying to connect a bud red light? If you are, you need to use the budweiser app, not the imp app.


#15

@Hugo, sorry whether I posted on wrong place. Actually, I am trying to use imp app to connect with Salesforce in order to attend a Trilhead module. One silly question, Do I need to buy any Eletric Imp kit?


#16

Ah ok, that explains the confusion then. You can start a new thread :slight_smile:

Think the trailhead is based on the explorer kit - is that what you have?

On blinkup - are you seeing a solid green at the end of blinkup? If not, then the device isn’t getting the signal from your phone. See https://www.electricimp.com/docs/gettingstarted/ for tips.


#17

I had the same problems, it turns out that you cannot use a 5G connection. Your phone has to be set on the 2.4g as well as the black box. After an hour of swearing, I changed all my connections and it worked for me. I actually had to use my iPad to set it up.
Hope this helps.


#18

Yes, there aren’t actually that many IoT devices that do 5GHz - almost all of them are 2.4 only. The red light originally came out in 2013 (when there were definitely no 5GHz IoT devices) so maybe they could do with updating their instructions to make that clear.

The phone doesn’t have to be on 2.4 though - but if it isn’t, you may need to manually correct the auto-suggested network name. On iOS, there’s no way for an app to know whether the phone is connected to a 2.4 or 5 channel.

Glad you got it working!