Budweiser Red Light (Version 1), issues with newer phones?

Hello,

I have had a Budweiser Red Light since the first month it was available way back when, and it’s always been referred to as a “Version 1”, and although I normally had no issues getting it set up, this year I just can’t figure it out. But only on a newer device.

I tried setting it up with new app, and my Samsung S20 FE, and no go, nothing I tried worked. I tried for hours.

Just a note, I am not needing a walkthrough, this is simply needing help with a newer device, because I decided to try some older equipment (Samsung S7, iPad Mini 2), and had NO issues syncing and setting it up.

All the settings I tried on the 3 devices (2 working no issues) are identical. 2.4 Wifi, SSID entered case sensitive (all caps on router and app), tried with and without password (unsecured), even changed phone to same wifi network while trying to set it up)

It refuses to sync on the newer S20, but works perfectly with the 2 older devices

Am I out of luck on the newer Samsung S20? Is it something with the screen flashing a different way?

I really don’t want to have a older phone charged up just to use one app.

Is there a way the imp can be updated to allow for the newer phone (if that is the issue)? I assume not?

I assume this is a very early imp001(?) for the Bud Red Lights. Mac Address: 0c2a69xxxxxx

Thoughts?

Thank you in advance.

Ask Budweiser; it may be that they have not incorporated the latest blinkup libraries into their app. I’m not aware of any issues with an S20, but I’ve never tried this either.

Googling this notes that Samsung have a compatibility switch that sets 60Hz screen update instead of 120. Maybe try setting that mode for the blinkup?

Hugo, Sir…

You are brilliant… I never even thought about changing the refresh rate to 60 Hz.

Once I did, it synced up right away…

God I feel so stupid now, but I will use this knowledge to help others that I have seen with same issues…

I also hope this will help others with this issue in the future.

Thank you!