Budweiser Red Light v2 won’t connect to app anymore

I have a red light device that has worked fine for several years, so this may be a Budweiser app question. The app kept crashing after the most recent update (version 4.2.3, December 2023) so I had to delete it and reinstall it.

Once I did that, the app no longer recognizes the red light (which does blink green and is connected to my wifi according to my wifi app) and the red light no longer sounds or lights up when a goal is scored.

When I try to ‘add device’ in the app and go through the blink up steps, it fails and one of the reasons is if the device is connected to another phone.

Is there a way to ‘factory reset’ this version of the red light so that I can connect it to the app again? I’ve tried removing the D batteries for awhile.

Does anyone have contact info (an email address, phone number, working website) for Budweiser app support? The support link in the app takes you to a dead page.

Mac of my red light is: 0c:2a:69:09:5a:06 in case that helps check my connectivity.

Thanks.

1 Like

I seem to have fixed the app issue already.

I found a mention in another forum post about the iPhone refresh rate needing to be set to the lower rate, so I did that and the blink up process completed and the red light is now connected to my app again.

On the iPhone (iOS 17.2.1) go to settings - accessibility - motion - and turn ON the ‘limit frame rate’ toggle. Then launch the Budweiser app and go through the ‘add device’ process.

2 Likes

This worked for me. Thank you for the detailed explanation. I have been screwing with this thing for hours!!!

The BlinkUp SDK supports high frame rates so it sounds like the Bud app doesn’t use the latest version (despite the recent update). But at least that’s a good workaround for apps that haven’t incorporated it yet.

Spot on! @kermitwallace Thank you for this post! I was losing my mind trying to fix this. Bud App should call this out as a troubleshooting step.

hey everyone, it took me hours before i found this thread.

For those who have first version of the red light, it does work on the new network 5ghz/2.4ghz (shared ssids). I use a ORBI mesh 6 wifi. just makes sure u connect it first on the 2.4 ghz… then turn on the 5ghz

So for hours, i was going nuts trying to get my light to sync and connect. But this thread solved the issue.

"On the iPhone (iOS 17.2.1) go to settings - accessibility - motion - and turn ON the ‘limit frame rate’ toggle. Then launch the Budweiser app and go through the ‘add device’ process. "

thank you for that.

Thank you thank you thank you. I could not figure out what I was doing wrong. This seems to have fixed it!

This worked for me to! Thanks !!!

so while that issue has been resolved… not sure if anyone else is getting…

now my redlight… will not light up for goals (after the terrible canucks vs wild game, it lit up 7 times) but now after that game… 3 games in a row now… not a single light up for any goal scored. for my set team or the opposition team (yes i got paranoid and set the enemy team as well). i reinstalled the app, set up the device fresh again too. it will however announce… 5 minutes til game… get some awful buds.

1 Like

Same here. The last couple games it’s not lighting/sounding when a goal is scored. It’s connected to wifi as I can make the light/horn go off with the ‘test’ button in the app, but it’s not working automatically. I’ll be watching for another app update…

A few days ago, I realized that the batteries in my V2/V3 goal light had been dead for awhile. I changed them out and got the flashing green status LED, but it wasn’t sounding for any goals.

I got a new phone (Pixel 8) since the last time I did anything with it, so I tried to re-link it with the Budweiser app but have been unable to do so. It was connected to my WiFi until I used the Electric Imp app to clear the WiFi info on the goal light 2 days ago. Now I cannot get it to connect to either of my WiFi networks using either the Budweiser app or the Electric Imp app. My WiFi router shows the goal light has been offline since 12:06am on Feb 22.

The light appears to recognize the BlinkUp process (the status LED stops flashing when the process begins, and resumes as soon as it finishes), but it stays flashing amber (or red, tough to tell). I forced my phone to 100% brightness and 60Hz refresh rate.

Mfg date is Dec 6 2014, MAC is 0c2a690ace71.

Is this all related to the current outage others are experiencing? It seems like I should at least be able to get it back on my WiFi. Any suggestions would be appreciated.

Have you heard anything yet? Mine is not working either? Would you have contact info for Red Light Support?

I believe the goal light support email is now support@scorz.com.au.

Thanks. I already sent them an email. Hopefull I will hear back soon. It’s a lot of money to spend on a what essentially is a door stop now.

Well the Red Light is still for sale on Budweiser’s website, so it would be surprising if they plan to kill it off yet.

I tried re-pairing my light today the same way I have tried dozens of times this week, and it suddenly worked on the first try, so something was resolved. Will see if it goes off with any games tonight.

EDIT: It is working again, tested with several teams.