Budweiser red light problem

I have a bud red light that worked fine last season.
I changed my iPhone and now I wanted to reprogram my light for the season starting tonight.
However when I turn it on, the imp led flashed red-orange-green, then it’s off for a few seconds then it turn on steady red forever.
Can’t seem to find someone else describing the same problem or a description of what steady red means.
I’ve tried to sync the imp with the app but the led turns red before the sequence end.
It is the imp, my network or the phone?

Im having the same kind of issue. Worked perfectly all season last year. Tried tonight. Blinks Red when i take card out then put back in. Do settings in app. Still blinks red.

@mdostie your unit appears to be trying to firmware update, but does not seem to be managing to contact the server.

If it sits there with a red light (not sure why it’s red, but…) for more than 10 minutes then try taking it to another wifi network and blinking it up onto that network. If that works - there may be a period with solid LED as it updates - then it’ll likely work fine back on your home network again.

@neooliver is it a fast red blink? If so, your batteries could be low in the red light. Does the test button work for you?

Same problem for me. Worked fine last season. Now won’t connect to my network. The Budweiser app says it timed out, the Imp card flashes orange-red-off. Tried to re-blink numerous times with no success. Talked to the Budweiser support and they have been no help. I just want to know if it is my router or if it is something to do with Budweiser’s servers.

@atrox what’s the mac address on your imp card?

@Hugo I forgot to take it down. I will reply in this thread with the mac as soon as I get home in approx 3 hours.

Or just PM me then too.

Hi Hugo, As soon as I turn it on, or pop the card out then in, starts blinking red. Then I do the setup. looks like its about to work, then starts blinking red again.
Horn works when i press the button though.

Same issue here - Steady red light on imp card??? Just received it 3 days ago and have not yet been able to get it setup on my WiFi…

@Hugo Same here…although technically mine is flashing orange. Never see red or green lights, and my router is a netgear wndr3700. The imp does not show up on it.


Flashing orange = no config. Your blinkup has not been successful. If you have a samsung phone, check power save mode is disabled.

Solid red = not a valid code. Likely your imp is faulty in some way (but first check batteries in red light).