Budweiser Red Light - New phone, new Wifi, not working

I recently moved, and I got a new Wifi network. My Red Light (v2/3) worked last season but hasn’t worked yet and won’t connect. The app states that if I had it connected via an old phone, it won’t connect to a new one. I can’t figure out how to get it reconnected now. When it blinks, it’s one long blink followed by three shorter blinks, all red. MAC: 0c2a6908c649

Long red + 3 short red = joining network.
see BlinkUp Troubleshooting Guide | Dev Center

It can find the SSID but maybe the password is wrong (or maybe encryption type has changed, eg to a newer WPA type and hence it can’t use the previous credentials).

I would use the imp developer app to clear the configuration, then use the Budweiser app to set it up again?

I am having a problem with my goal light as well (Budweiser V1 Goal Light won't connect to my WiFi - #3 by JaronA). It looked like Jaron was going to take care of it, but I haven’t heard anything from him. Is there any chance you can help? Thank you.

I’m not able to help - I no longer work at Electric Imp/Twilio. However, if the imp is doing a long red/3 short reds, the issue is not related to the service - you should just blinkup again with the red light app.

It’s not giving those light codes. I have tried multiple times to connect with the app and it won’t connect. I run threw all of the procedures to connect with the app and it just doesn’t connect. after a while the blinking sequence for connect just stops and won’t connect.