Budweiser Red Light DHCP issues

Hi all,

I’m hoping I can get the attention of someone with advanced skills. I have a Budweiser Red Light and after 2 weeks of troubleshooting, I cannot get it to stay connected on my network. I’ve had a few times where it will link up but then drop back out shortly after, I’m not sure why.


  • I have a Cisco AP 2.4 GHz band, 802.11b/g. SSID is hidden and I’m running WEP 128 bit key.
  • I can get the IMP to blink-up successfully; verified by the quick green light from the IMP after the programming
  • I’ve tried 3 different DHCP scenarios, none work completely (I’ll get into more detail later)
  • I can access, outbound from my inside network, imp.electricimp.com on TCP port 31314 (telnet from a Windows system to that destination on that port opens a socket connection)

1st DHCP scenario - My DHCP server was on my MS Windows server box. Rarely would the IMP ever get an IP.
2nd DHCP scenario - I have a 3560 as my “core” for my house. Putting the DHCP pool on this, not much extra luck.
3rd DHCP scenario - I put a DHCP pool on my Cisco AP; like the others, not much different.

Also to note, on all 3 scenarios I’ve tried DHCP reservations - no luck too.

Real nitty-gritty details:

Per the logs from my switch and AP, here is what I see:
Sometimes this:

  • IMP comes up and associates to my AP, no issues at all
  • I see the DHCPDISCOVER come in from the IMP
  • The switch will send the DHCPOFFER but then no reply back
  • Switch then sends a broadcast for BOOTREPLY
  • this process repeats

Sometimes this:

  • IMP comes up and associates to my AP, no issues at all
  • switch receives DHCPREQUEST from IMP
  • switch sends DHCPACK to IMP
  • No reply
  • this process repeats

I’m not sure what the deal is, but its like the IMP will not take an IP address any system I setup offers.

Here’s the kicker, I took the Red Light to my cousin’s house to see if it was something on my side (this was prior to all the advanced debugging I’ve done too) and the thing links up without a problem and worked! All he has is his ISP’s modem/router that is also an AP built in. Now, why does that generic thing work and my “enterprise grade” stuff not work LOL. Makes no sense at all.

Any insight, ideas, etc. is greatly appreciated.


As you’re obviously pretty technical here, any chance of a PCAP of a failed DHCP attempt? We can then take a look at the actual traffic and see what might be upsetting the imp.

Hi Hugo, I was hoping you’d respond. :slight_smile: I read many other discussions before I posted (obviously I didn’t find anything in common) and you seem to be the SME. I’ll take a PCAP spanning the port my AP is on. That was my next step. Thanks for replying!

You can email the PCAP to dev-team@electricimp.com as posting it publicly may leak more information than you’d like… but very interested to look at this.

Awesome - thanks! I’m sending it right now and will dig into it myself. I captured the raw feed and then created another file which filtered out everything but DHCP, the filtered file is what I’m sending. If there is something more you’re looking for, I’ll prolly have it in the raw file - just ask. Thanks for your help!