Budweiser light wifi issue not connecting

I am having problems connecting/setting up my budweiser red light on my iphone 4g phone. Wifi network is correct, password is correct, upper and lower case all good. My electric imp is blinking orange. tried different settings but I believe my issue might be with my router, I read some posts and seems that they also had the same issue. Security is WPA2-PSK security on a N band router, using Dlink DIR-601 Model.

Any help would be appreciated.


have you checked that your wifi channel is below 12?

If it’s blinking orange, then it hasn’t noticed your phone at all: the router can’t (yet) be the problem. Make sure you’re holding your phone’s screen right up against the blinking light at the end of the imp. Sometimes it works better in a darkened room.



Thanks for the codes, I tried in the closet, which is pitch black except the brightness of the phone still didn’t work, I have had the unit touching the chip on contact from the screen, any closer and would be inside the unit.

I am not sure how to check my wifi channel, I will have to contact dlink for help… thanks for your help any other things to check let me know. will keep posted if the router thing worked, ive pretty much tried touching, 1/4", 3", 6" away from the chip

unfortunilty when I called Dlink, they found that I can not access my router to determine what channel its on which was about 1 hour on the phone, this will have to wait till a replacement is sent, so I can’t determine what channel its on.

You might use an app on your phone for sniffing wifi networks, to see the channel being used

I have to go buy a router, im out of warranty, does it matter which band wifi I get, like G or N, I perfer N than the dual.

Still not have any luck, just picked up my new router, set it all up, bought a multi band router for wireless and set the channel to 6, then to 11, in a dark room with the iphone touching the white card… any other possibilities?

I have an idea, but it might not solve the Bud Light issue.

Buy an Imp and April Board from Sparkfun and when you get it, try blinking to it.

If you can blink to your own Imp that you bought, you’ll know that the problem is with the Bud Light.

The best part about buying your own is that you now have something cool to experiment with. I think it’s like $55 when you buy both and include shipping?

If you’re using iOS7 on an iPhone4 (not 4S) then it’s possible that budweiser didn’t incorporate the latest fixes that are in the imp app.

Try quitting all background apps, and doing the blinkup from a fresh reboot of the phone, or try with an iPad or other phone.

Ok, i tried the ipad and now the light is red blinking, here is the pattern.
two fast red blinking, then slow red blinking 5 times, then repeat two fast red blinking then 5 slow red blinking… I also tried another iphone and no luck as the first, I think with the Ipad has gone further

Sounds like your SSID or password is incorrect as it is not able to join the wifi network. These are case sensitive, re-check this?

yay it worked, it was trying to connect to my 5g network instead of 2.4g, the name is virtually identical, same password for both.
Thanks I got the green light and is good to go… GO TEAM CANADA

I’m having the same issue. I have my Red Light connected to a 2.4 GHz linksys router (no password required) - same with iPod being used to configure the light. IPod is pressed right up against the IMP card. Only getting flashing red - no orange or green. Tried several networks to no avail. Mac is 0c2a690141ea. Please help.

Sure the network name is correct (it’s case sensitive)? Red only means it’s not managed to find the network it’s configured for.