Budweiser Imp card only flashes red

Hello all,
I know there is an abundance of these threads currently and I’m sorry for adding to them but I just can’t figure this out on my own. I bought my dad a Budweiser red light last season and it worked great the entire time we had it. Over the “off time” between seasons my parents had their internet router changed and now no matter what we try and what settings we change in the router, the imp card only flashes on and off red for about a minute, maybe less, and we get a time-out on the app(iPhone4). We’ve tried it on a number of different cellphones and have changed the D-Cell batteries in the light itself.

I have the mac address and all other numbers off the card handy, just let me know if you need them. Thanks much.

First thing: do you get a quick green flash at the end of the blinkup process? This signals that the imp got the blinkup data.

I’m on my second red light - same issue. Flashes orange/red/blank then after the blink, there is a short green flash… then nothing, no connection. My app times out. Using a iphone 5, router is a hitron from rogers, which works great with everything else?

Update - I rebooted my router, tried again, this time the light flashed green then went to sleep… the app on my phone timed out. The voice message at Budweiser suggests that eventhough the app timed out, it will still work?

Seems like it’s working, did it not go off when you hit the test button in the app? The logs say it did.

Sorry for the terribly late reply! One time (out of probably 50) we saw a very very quick green flash, faster than the green flash we had seen last season when the light was working.

MAC is 0c2a69014a5b.

Yeah, not seen by the server since late June. Can you try it on another network to see if it’s disagreeing with the hitron router?

I’m back. I switched from Rogers to Bell over the summer and cannot get my Bud Red Light connected again. The IMP card flashes orange very quickly only. mac: 0c2a690148f7