Browser problems

Looks like IMP have a serious browser compatibility problem. My laptop at home is running Google Chrome and XP. I can’t see any devices. My work PC running Windows 7 and Google Chrome can’t see any devices. My work colleague is running Windows 7 and Firefox he can see all my devices.

I install Firefox on my home PC I can’t see anything. I try Windows 7 on my home PC can’t see anything let alone login tab. If I look at my WiFi connection all devices pop up.

I have done all the obvious Blink Up checked that the LED codes are OK etc… There just seems to be no association with my devices and my account.

Any advice would be greatly appreciated

At the risk of asking the obvious, did you happen to BlinkUp to your colleague’s Electric Imp account instead of yours? Devices will only show up in the account to which they are blinked up.

No, blink up to my account, About a year ago now I had no problem seeing the devices. A year later now I have been trying everything to see the devices. Nothing has changed on my side. I have several IMP modules but only two have been populated onto boards. I managed to see my DEV Module (IMP001) once when I registered a new account that is now not working as well. I am pretty sure that the guys at IMP could verify but I have had no response from them.

Just to check (since it’s a year or more since you last tried this), you are trying to access, aren’t you?

You might also want to try clearing Firefox’s (or Chrome’s) data caches (saved passwords, etc) in case these contain old data that’s preventing you from logging in.

I use Firefox on Win 7 Pro to access my imps, I just checked with Chrome and it works fine for me. So there is no inherent problem with Chrome on Win 7 Pro.

Make sure that the model containers in the left sidebar are open - the arrows should be pointing down, like in the attached screenshot. Click them a couple of times to make sure!

Thanks for all the advice
Hi smittytone, correct access for IDE so no issue with that. Did the cache thing as well
Hi gino, no active modules :frowning: on display. I have tried another PC at home no luck.

Can you give us the mac address of one of the devices (0c2a69xxxxxx)? Will look and check they are actually on your account.

MAC: 0c2a690025ff
MAC: 0c2a69022760

They both seem to be on your account, one is “Garage opener” and the other is “Relay board”.

Your original email implies that some combination of browsers works for you? Are you sure you’re logged into the right account? (should say “ThaiLes” top right when you are in the IDE). Could you attach a screenshot of the IDE?

Attached IDE Screenshot. Logging into correct account. BlinkUp to correct account. I even cleared device setting then did it again. I can see the device if I check my WiFi settings see below. This is crazy there is know way I can see the device.

Connected WiFi Clients
ID IP Address Host Name MAC Address Duration
6 0c:2a:69:00:25:ff 00:03:23

From that screen you should see your imps when you click on the arrow next to one of the Active Models, which must all have devices linked to them. Or do you have different working imps on those models?

As drjack says, try clicking on the arrows by each imp model. This will pop open and should show the imp associated with that code.

Sorry chaps, I know that each module should be associated with a project. But in order to associate the code with an IMP Module I need to see the module in the Unassigned/Assigned Devices first. I see no assigned devices. This is not the first time I am doing this and I have a good idea how the IDE should work as I have coded a few projects successfully in the past with the same computer same operating system etc… Now revisiting the projects I am at a complete loss what is going on and that I cannot see anything! That is why I tried other operating systems and computers to investigate. I had luck with some combinations as described in an earlier posting. During that exercise I logged in with a new username “impme” If I go back to this username IDE on this PC I also have no luck.

Active Models have, by definition, devices associated with them. From your screen grab, I can see you have active models (such as Garage Opener). Taking that as an example, click on the triangle to the left of ‘Garage Opener’ in the column on the left-hand side of the screen (we call this the Model Navigator). This should present all the devices associated with the model Garage Opener.

You should see something along the lines of the attached image, ie. a list of devices below each model, themselves filed under Active Models. In my pic, april_led, BLE, Clock 4.0 and HomeWeather are models; Battle, Cløck, Warlord and Buster are all devices.

If you want to change a device’s association, you need to reveal the device in the manner described above and click on the gearwheel icon to get the Device Settings panel. Here you can switch the device to a different model.

You have selected the model, not the device, which is why the workspace area on the right-side of the screen is in model mode. You can tell this because there’s no log pane at the bottom of the screen and no device is listed below the model name (in the workspace). Click on the blue ‘Garage Opener’ that has a triangle to the right of it and, again, you’ll see a list of the devices associated with this model. Select one to open the workspace in device mode. Now the log pane will appear.

FWIW, the @ThaiLes screenshots show “Active Models” with the triangle pointing to the right instead of down and yet has the active models listed. This can be a bit confusing and I believe I’ve seen this in the past, but I’m not certain.

BTW, I do not believe there is an “Assigned Devices” collection–I’ve never seen this. When imps are first blinked up to an account, they appear in “Unassigned Devices”. Once they are assigned, the go from the “Unassigned Devices” and are listed “under” the model to which they are assigned and can move from model to model as requested.

I’m wondering if the behaviors in the IDE have changed since @ThaiLes last used it a year ago and that may also be complicating the experience. I haven’t been around that long. Just a thought.

@hvacspei yes that is a bug, thank you

@ThaiLes your devices are all there, hidden by the collapsed models. All you need to do is click the arrows next to them, like smittytone, myself, and Hugo have all noted. Please do that.