Bringing up a new board

This might end up being a BlinkUp issue, but since I just reflowed a new board it could be just about anything… :slight_smile:

After power up, I’m getting a blinking red LED (about 500ms on, 3 second cycle). This doesn’t match any of the listed BlinkUp LED patterns so I’m trying to figure out what I’m seeing. It’s a 004m, brand new never been configured.

I initially had an amber light, then I tried and failed BlinkUp, now I’m seeing the red-only pattern.


Sounds like the SPI flash isn’t programmed? Did you load the spi flash image for the 004m?

You can use any SPI programmer for this, or if needed you can buy pre-programmed SO8 flashes from

Ah, ok, thanks for the direction. I used some pre-programmed flashes but there was some, ah, rework in that part of the board. Now I know what to do.

Thanks again.

Hugo, thanks again for your direction this morning. I got my second board into the pre-blink up LED pattern and was (I think) able to complete blink up - but my board is now giving me a single red LED flash just as the first one did.

Are you checking for flash before or after blinkUp? If after that’d continue to point to a flash problem. If you check the flash before then I must have a problem unrelated to the flash since I’m getting the blinkUp pattern…

I’ve also been tuning the blinkUp bias resistor. I think I have the value right now (I’m getting ~500mV swing voltage into the Imp from the optotransistor). Is there any chance I corrupted the flash/config as I was tuning?

I am using preprogrammed flash I ordered from the site by the way.

Thanks again for your help,


Some progress and a request for more help. I am now able to BlinkUp and clear settings reliably. However, after blinking up - and getting the green confirmation light - I am still going into the 500ms Red, 2.5s dark pattern. So I tried doing BlinkUp with WPS. I get the “WPS in progress” pattern and my router’s waiting for a client. But then I’m timing out. I can replicate this on two boards.

This would seem to point to an rf problem - but are there any other possible configuration issues or failure modes that might be the cause? I am on line power so I don’t think I’m having a power issue (but it’s a new board so…).

Thanks for the help,


Just got it working! Had one board error that was the problem. Now on to the non-Imp portion of the project.


Oh good - what was the issue? Seems almost like power, that pattern sounds like power cycling…

I am embarrassed to tell you. :slight_smile: Failed to connect VDD_WLAN to, well, VDD. All those bypass caps were there though. :wink:

A quick solder bridge did the trick. I also incorrectly stuffed a .1uF bypass on the flash, which might have accounted for some of the problems. And I used a different photo transistor than the one on the breakout board and it needed a larger bias resistor (I think it could still use some tuning but I can save that for later).

I’m really glad I could get the Imp running - I should be able to shake out a lot more issues now than if I’d’ve had to spin the board to get the Imp up.

Thanks again for the help,


One note - if you think you’re seeing a very insensitive blinkup phototransistor, double check it is in the right way round.

Phototransistors will still sense light - very badly - when reverse biased. We’ve seen this many times before!

Thanks for the tip - I’ll check that out tomorrow.