Bringing device online again


I’ve impExplorer Kit, with imp001 card. I’m not a very tech-savvy person, I just got it just for an IoT experiment at home.
And I set it up successfully couple of weeks back, and everything worked well.
Since then I did not do anything on it, removed the power supply to it & kept this device idle for sometime.

Today, I put the batteries back in the device, and again logged into my account, and see that it shows the device as ‘offline’.
I tried to restart it from this impcentral portal. But no success !
Can you please help me through this?
Do I need to un-assign, and reassign the device again?

Thanks !

Did it connect when you put the batteries in? Whenever the Kit is powered up, the imp001 card’s LED will flash as it connects (or attempts to), so what pattern did you see?

PS. No, you shouldn’t have to un-assign and/or re-assign the device, or even re-Blink it, unless your network has changed.

Thanks for the pointer !
I tried to power it with USB, the LED flashed and device came online. But with batteries, it doesn’t.
I guess there’s something wrong with the device, while using batteries, as I’ve put new batteries in it.

Thanks again !