Brand new Imp stuck at downloading update?

I just received my first Imp and started setting it up.
BlinkUp for WiFi-settings worked, the device shows up in the IDE and I assigned it to a new model.
However, the blink-light indicates that it is downloading an update for a few hours already (alternating short and long green blinks, also after a reboot and positioning it next to the router).
Besides that, I can’t find a log-window in my IDE and clicking on the device in my model only shows “There is nothing to see yet! Click on a device to start editing!”.
Other things I have tried:
-Setting the WiFi-channel to 6 (so not outside the 1-11 range)
-Downloading the upgrade-file via my phone over the exact same network (no problems there)

I really don’t know what I’m doing wrong here, does anyone have a clue?..

Try moving further away from the router? It may be drowning in signal.

Also, just yank the power. It sounds like the imp has begun downloading, but the connection has been lost, ie. it’ll report for evermore that it’s downloading. The thing to do is to force it to reboot, at which point it will re-attempt to download the imp OS update.

This happens twice: once (with the green flashes) so the update can be verified, next (solid green) to install it to Flash. Downloading is separate from running code, so this won’t brick your imp.

Does anyone know what network settings could have caused this?
I tried again today and still no luck.
I then set up a hotspot via my cellphone, connected to that network and within a few minutes the update was finished.
Now the imp is running via the normal WiFi-network with no problems at all. There are no other networks nearby and the WiFi-signal has about 50% strength according to my cellphone. There are no strange blocks or rules in the router and my internet-connection is just plain ADSL, I’ve never experienced any weird behavior with my connection.

I’m glad everything seems to work now but I’m still very surprised there seems to be a connection issue via my WiFi-network.

That’s very strange. Can you give any more detail about your network? (router, modem, internet provider)

Looking in the logs I can see the attempts from your phone/desktop but no attempts from an imp before that point, which rather implies that it couldn’t resolve the server DNS.

I see the successful update after too.

My (Dutch) provider is Tele2 with a normal ADSL connection. The modem is a Davolink DV-2020 provided by them. My router is a DIR-655. The modem has the router as it’s only client, the router is also in the modem’s DMZ. The DIR-655 handles all the LAN and WLAN clients in a new DHCP-range. DNS and default gateway point to the modem. There are no virtual servers, port forwards or other filters active on the modem or router.

I did do a quick check in the router whether the imp was actually doing anything. When it was stuck at the updating process yesterday I found only 1 line in the router’s internet session list coming from the imp’s IP-adress.
Unfortunately, I didn’t save all the information but the session pointed to IP (port in the 3xxxx range if I recall correctly).

I hope you can find anything useful in this information.

When it was doing the update, it would have been trying to connect to port 80; the 31314 port is when it’s normally connected.

However, the entry in the NAT table for the 31314 is likely to have a long timeout (typically an hour) so it’d still be listed. If you didn’t see anything on 80 though, that implies that the imp was not able to even make that connection.

Do you have DNS relay turned on? The DIR-655 has a buggy one of those, though I was under the impression that we put in a workaround for that problem a long while ago.

I checked again today and noticed that one of the two entries of the imp on startup had a timeout of 30 seconds. I’m not sure whether I was that quick into the session-list when the imp was stuck so there might have been another entry there that was gone before I saw it.
Yes, I do have DNS relay turned on.
Is there anything I can test to help figure out whether this is a wider issue? I’m happy that everything seems to be running fine now and that I didn’t make an obvious mistake but I’m willing to help if you want to investigate some more.

One thing we could do is force an upgrade on the unit (to make it try to fetch again), to try to replicate the issue. If this upgrade then fails, then you could try things (eg: turning off DNS relay) and see if that helps you.

Which rev of DIR-655 do you have? (there are many, many revs, see bottom label)

I’m fine with triggering another update, I don’t have any short-term projects planned for the imp.
My DIR-655 has hardware rev A5 (written on the bottom, the webpage states A4) and software 1.31EU

Ok, I’ve queued a later version. See if it gets stuck, and if so, please try turning off DNS relay, restarting the router and, if it still seems stuck, restarting the imp.

Thanks for the help!

I’m afraid I can’t be of much help any more… this update was processed without any problems at all (and no settings were changed in the router or modem afaik).
For what it’s worth, these sessions showed up in the router:
Local NAT Internet Protocol Time Out TCP 7800 UDP 29 TCP 7785 UDP 14

Let me know if there’s anything I can do to be of further assistance

Yeah, those connections look normal (DNS to find imp server, imp server connection, DNS to find upgrade server, http connection to fetch update).

Hmm. Very strange as the bootrom that does the upgrade fetches has not changed.