Blinkup works on Hawkin HWREN1 not on D-Link DIR655 Router


#1

Problem in a nutshell…Imp doesn’t communicate with D-Link router but will work with a Hawkin Router.

In my office I have a D-Link DIR 655 router for office work and use a Hawkin WREN1 routed as a range extended in the garage for our house. I can blinkup in the house (on a Galaxy Note) over the wifi created by the Hawkin but not in the office over the D-Link. In the office I can log onto the D-Link with a Chromebook, an S5 phone and the Galaxy Note but can’t blinkup.

Am trying to automate soil moisture data retrieval from our orchard sensors and need to use network in office. Using Vinduino and LoRa transmissions to a gateway.

When I try to blinkup over the D-Link the Imp flashes as follows:
1)Steady Green for a short time
2)two red flashes about equal duration
3) one red flash and then 3 shorter red flashes
4) red flashes then repeat, no green flash

I can “Clear a device’s settings” but I think that is in my devices and not working over the D-Link.

What I have done/tried so far:

I do have passwords correct.

Router is 2.462GHz on channel 11.

Enabled and disabled DNS on D-Link…no change.

I have unplugged D-Link and re-powered ,no change.

I have repeated blinkup procedure dozens of times, in the dark, on various locations on either phone or tablet…no change.

To quote the movie Cool Hand Luke…What we have here is a failure to communicate!

Any and all help gratefully accepted… I am a farmer so type slowly and try not to get too technical with your suggestions…

Thanks in advance


#2

The BlinkUp troubleshooting guide is here: https://electricimp.com/docs/troubleshooting/blinkup/

What’s the mac address of the imp?


#3

@farmer1949, it looks like the imp is getting stuck trying to connect to the network (long red, three short red) which it has found (log red, two short red), so your SSID is right. Does the D-Link put up a web sign-in page when your other devices join? That will certainly block the imp. Another issue might be that the D-Link is serving up a limited number of IP addresses and there are none left for the imp, so that’s something to check in the router settings too.


#4

smittytone:
D-Link doesn’t put up sign in page for new device…I just put in network name and password on each device’s WiFi settings and then that device is connects.

I disconnected the Hawkin router and tried again…still same problem,I am limited in my tech knowledge, I can’t find a place on the router’s settings where the number of IP addresses is set…so I just unplugged the Hawkin to try and “free up” an address…no go…any other ideas?
Thanks


#5

As you’re getting a solid green from the imp, the blinkup part is working fine. No need to go into darkened rooms etc - the green indicates that the imp received a complete, uncorrupted, blinkup packet.

So, this sounds like there’s an issue with the password or something to do with encryption. Long red, 3 short means joining (so it found the network, implying the SSID is fine).

Can you send a screenshot of the “Wireless settings” screen on the router? (see p27 of http://images10.newegg.com/UploadFilesForNewegg/itemintelligence/dlink/DIR655B1manual070312v23pdf1404106543155.pdf ). Do you have the hugely long hex password, or a short one?


#6

Hugo
Password is simple like me…

The settings are an attached file


#7

Here are more settings from the same page…thanks


#8

here is first screen shot that is slightly clearer…


#9

All those look totally normal. We support AES/TKIP WPA/WPA2. Is the router upgraded to the latest firmware available for it?


#10

Hugo, you the man! Updated my 2010 D-Link firmware and after going through the normal pain of resetting passwords, etc…I was able to blink up my Imp in the office on the D-Link…Thanks sooo much! Now I still have a few more hitches but this was a tremendous help. Thanks again.


#11

And I was able to blink up using my Galaxy S5 phone which is much handier than borrowing my wife’s note…


#12

Excellent! Glad it’s all sorted now! :slight_smile: