BlinkUp woes .. Imp-002

Have been using the -002 for a long time, have never had any BlinkUp issues that I couldn’t resolve, have measured the various tri-levels, adjusted the opto resistor, etc., but I have run into a brick wall with a new batch of -002’s that just don’t seem to want to work … I just can’t get them to take WiFi credentials.

Power on initiates a quick red flash followed by the repeating orange flash (500ms ON, 500ms OFF) … normal ‘no network’ status. BlinkUp starts out as usual with the LEDs turning off, but somewhere along the way things just revert to repeating orange. No chance of ever getting to the green flash. (Clearing device settings work fine every time … can always get the green). Fyi, I only use iOS devices for BlinkUp.

I’ve checked my hardware layout and assembly … everything looks solid, and it’s a circuit/layout I’ve used previously without issue. As mentioned, it’s seeming increasingly likely that it could have something to do with this ‘new’ batch of -002’s I’ve just broken into.

(For a little background, I picked up this particular batch of devices a couple years back when @Hugo was able to scrounge up a small number that were still laying around the office).

Anyway, before I bang my head any further, I’m just wondering if there is something else I might try, or if it indeed could be related to these -002 devices I’ve just started to try. (I’m 0 for 2 at the moment … I’ve also been just limiting things to trying to get the BlinkUp functionality going). I realize the -002 is well past EOL now, so just let me know if I may have to punt on this one and set these devices aside.

Thanks,
Larry

Just to confirm, are you seeing a long red flash from the imp before the iOS device has finished the blinkup sequence? That would indicate a reception error. I would check the iOS settings for Display/Brightness and Accessibility/Motion and disable anything that adapts the screen brightness.

Do you have existing imps successfully blinked up to the same wifi access point?

The scrounged devices probably have an old impOS version and may perform better once you first get them online and updated. I would try an older iOS device if you can, and also reduce ambient light as much as possible.

If you DM me with the mac addresses of the two you’ve tried, I can try to check their history.

Thanks for the quick response @phil. No, the only red flash I observe is a very brief one (maybe 250 or 500ms ?) right at power up … followed by the 1s orange (amber?) repeat. There is no further red flash … the device will just revert to the orange blink at some later point during BlinkUp. I’ll double check all the brightness related settings you mention (which I’ve used before), but this doesn’t seem to be reception related. (… and I’ve tried various brightness options, including working in a dark room).

Yea, I’ve BlinkUp’d other devices routinely to two APs I’m tying to get on now with these recent -002’s.

Good suggestion on trying an older iOS device … I’ve got an early (first?) gen iPad laying around which I note still has the EI app loaded. I’ve got a few things going this morning, but will give that a shot a bit later. Will let you know, and also DM those MACs if necessary.

Thanks again,
Larry

I spent a bit more time with this earlier this afternoon. Unfortunately, the situation is the same when I tried BlinkUp with the older iPad … nothing doing. (All tests done in a dark room holding the iPad at various distances from the device to generate different waveform levels … two different OPTO_IN resistor values also tried, 51k and 100k). Out of the dozens of BlinkUp attempts I did see (only) one which was different - three quick red flashes in the middle of BlinkUp - but other than that, nothing but flashing orange.

For completeness, I swapped out the -002 in my circuit with an older device which I knew to be working … (it would have a current OS). No problem at all … BlinkUp fine on the first try.

So, my confidence is very high that there is very likely nothing wrong with my circuit, the opto R value, waveform levels, BlinkUp device/technique/lighting, etc. … but that there is something very different with these recent -002’s that are making them very stubborn to loading credentials.

DM with MAC addresses has been sent … any other suggestions would be welcomed.

Thanks,
Larry