BlinkUp not working with Asus Zenfone 2

I can’t get BlinkUp to work with my Asus Zenfone 2. It works fine with every other Android phone I have tried. I have tried every combination of screen brightness and power saving with no luck. Is this a known issue? Is there something I am missing?

Thanks in advance,


FWIW, we have had other users successfully BlinkUp using the Asus Zenfone 2. Tried legacy mode?

I have tried legacy mode and everything else I can think of. Other phones work fine. Perhaps I need to buy a cheap Android just to BlinkUp.

Has the imp you are trying to blinkup been configured before? The imp001’s are pretty old (most were made in 2012) and the blinkup algo was improved a lot since then. If you can get it online once (any network, any phone) then it’ll update.

These are IMP002s on MakeDeck boards and a few assorted 001s. They have all been configured before using a borrowed S3. I solved the problem today by buying an LG Lucky for $20. That works fine.

Out of interest, does the Zenfone 2 have a particularly dim screen? Which exact model number? (if there’s a model displayed in the about screen, that’d be useful)