BlinkUp Errors - iOS

Recently, (end of last week) we’ve noticed huge issues with the BlinkUp when going between networks. Our first BlinkUp, at our offices, goes smoothly. When taken to my house to test re-BlinkingUp on a new network, chaos ensued.
The Imp LED blinks RR-R-R-. Neither BlinkingUp the new credentials nor clearing works. Either the LED continues to blink the same pattern of RR-R-R- or it stops blinking all together. (However, sometimes the phototransistor was still operational and would notice the BlinkUp - yet wouldn’t take the credentials.)(FYI - This is all with the solder down Imp)
I continued to go back-and-forth between home and office to test and retest - usually getting the same results. If I cleared the credentials at the office before going home, BlinkUp almost always worked.
Initially this was all done with my iPhone 5 iOS 7. Using a co-workers Android device with the newly updated Electric Imp BlinkUp App I was able to BlinkUp all devices first try no matter the network, or above situations.
Furthermore, we’ve noticed that the Android BlinkUp lasts 2,3 or even 4 times longer than the iOS BlinkUp with the same credentials.

Has anyone else had this issue?? Is the iOS App out-of-date? Have recently firmware changes made this a problem? I’ve never noticed this before, but am currently more attuned.

This problem, being so repeatable, is very significant.


I am curious as to what board the Imp module is on? What are you using for a Blink-up circuit?

As noted in the support ticket, this sounds like an issue with iOS, as android works fine. Turn your iOS device off totally and on again and retry?

Sorry for the late response.

The Imp module is on our board. We have a 10k resistor on the diode. As far as we can tell there isn’t documentation on what resistance to use. It just says to put resistance on the diode. We’ve stuck with 10k cause we’ve been using it for so long and haven’t had an issue. This issue just sprang up last week.

The hardware team asked for our schematic and we’ve sent it to them. We are anxiously awaiting a response.

10K seems awfully low. I believe the values recommended have been 47K, 68k and 100k. I’ve been using 100K with all 6 of my Imp modules.

There’s a doc on the website that takes you through the process of picking the right bias resistor:

Not sure of the best place to post this, so I’ll try this discussion. I’ve been having issues with Blink-up using a new iPhone 5S with the most current iOS. Lots of frustration until I remembered somewhere reading about iPhones perhaps “overloading” the Imp due to the amount of light. So…I turned the display brightness down to about 25% (from ~80%) and it worked just fine. I repeated it after clearing the wireless configuration and it worked again, first time. Whew!

That’s very strange; the blinkup app controls the brightness level anyway, so user settings are ignored (it turns it up to 100%).

Are you covering the side of the imp during blinkup? The main issue is not saturation but not getting dark enough when the screen isn’t white.

I had tried covering the side of the imp, but without any success. In my office, I had trouble until I turned off the fluorescent lights in the ceiling. I also had repeated problems at home in my kitchen (only dim incandescents) until I tried turning down the brightness on my iPhone. Having said that, I just confirmed your comment that the app turning the brightness up in spite of my reducing the brightness level. Now I’m confused, but still happy that it seems to work, for what ever reason! As the commercial goes, it’s not weird as long as it works!