Blinkup by Collaborator doesn't work (anymore)

We have the following situation:

  • main company account is used to develop & deploy development devices and production devices
  • for the production devices we have our own blinkup app. No issues
  • for the development devices often used in a pilot, we need blinkup capability by both our own employees (using the main account credentials) and a limited group of partners that we don’t want to give our credentials.
  • to support this, we created a collaborator on our account with only ‘blinkup device’ role. This collaborator has also an account itself which does not contain products at all (is also not the intention)… The whole back and forth procedure was followed, collaborator shows up in our account under the collaborators and our main account is visible as having invited the collaborator account.

When now such collaborator uses the eImp blinkup app on one of our devices that was assigned to a particular development group, then instead of keeping the assignment and executing the blinkup to bring the device online, it does the blinkup (which succeeds) but unassigns the device from our account after which is shows up under the collaborator account as ‘unassigned’. When repeating the blinkup with our own main credentials, the device shows up again under the correct development group.

I remember when frist setting this up, the scenario worked as intended, but now, after experiencing some trouble in the field, it doesn’t anymore and shows the above described behaviour.

What do we do wrong ? I guess a scenario where a third party can blinkup a previously assigned device without changing that device assignment and without needing the original account credentials is possible, right ? Should we have created a collaborator (email/password combination) that is not associated with a separate account? I seem to recall that this was not possible when creating the collaborator, but I’m not sure.

We basically just need a separate login for the eImp app with which one can do blinkups for our devices. Nothing more.

ok, figured it out myself…
When testing this initally we followed the correct procedure of activating the ‘use advanced settings’ Target account to switch to our account, which does work !

I was going to post this,, which is the doc the discusses what you need to do, but you’ve figured it out. I’ll keep the link here for the record.