Blinked Up my IMP and it flashes green, but doesn't show up in my account

A friend was helping me and the IMP was originally in his account but we deleted it from his account. Now it doesn’t show up anywhere. Any suggestions?

Here’s what I would suggest:

  1. Double check what account you’re logged into (both in the mobile app, and the IDE).
  2. In the Electric Imp app, do a “Clear Configuration” BlinkUp for your imp (this should result it blinking orange) - this way you can be absolutely certain it’s on the account you think.
  3. BlinkUp to your network / account

I have the same issue on my two IMPs and I tried the procedure above, but in vain.
Do you have any idea?

MAC: 0c2a6900428d (model: IMP001)
MAC: 0c2a690049d0 (model: IMP001)

@yskim did you get this working? I can see those devices booting on 5/27.

No.I just tried them again. They don’t show up in the IDE although they are blinking green.

Looking at these: the reason both these devices are not appearing is that they are inserted into blessed (production) devices.

You’d need to unbless these devices if you wanted to use them for development again.