Blink-up Failure - Imp does not connect


#1

I’m using an imp001 dev edition and April setup purchased from Mouser.
Immediately after blinkup, device vibrates, and the app says “gathering device data”. Once the green ‘status bar’ on the app completes, the app states “device failed to connect”.
Meanwhile I get no visual feedback from the imp card. It only flashes orange upon power up or when I clear device settings.

I’ve tried connecting to two different 2.4GHz home networks, and disabled ip4/ipv6 firewalls on the off chance that’s it. Have tried channel 1 and 11. I’ve also attempted to connect with my phones hotspot. No dice. I’m using the s6 edge, which is on the list of verified devices. My mobile device logged into my own personal account on the mobile device which matches the account I created here.

Anyone have some ideas?

Also, is there some way to run diagnostics to get more info? @imp dev “device failed to connect” is pretty useless…


#2

Just some additional details,

-I’ve powered up from usb serial port and dedicated 1A ac-USB adaptor
-I’ve also tried it in the dark

Any suggestions would be appreciated. Thanks


#3

dev edition is very old (software is likely 2012 vintage); you will likely need to use an iOS device to blink it up first so it can upgrade its OS. You may have some luck using legacy mode in the android app if that is still offered as an option.

After the OS has been updated to a more recent version, you should have no problem with using an S6. The kits on amazon are pre-upgraded but I don’t believe stock at places like digikey are (mouser don’t sell the imp001?)