Blink-Up App for Windows


#1
To help those currently awaiting the iOS app and those having trouble with the Android app, I've knocked up a Windows application to commission imps. It's only been tested on a few machines so far so I'm sure it has bugs - if you try it please let me know how you get on.

Download link is at the bottom of this post:

http://fenconsultants.com/blog/?p=63

Hope someone finds it useful.

Rob
Fen Consultants, UK

#2

Kudos! Just tested and it worked fine except for one hitch.


Running Win 7 SP1 x64 and I just couldn’t get past the sign in portion. I eventually had to run in XP SP3 compatibility mode. I’m sure people will find this helpful.

Thanks!

#3

Woo-hoo !!   Nice work Rob !   After spinning my wheels a few days this week trying various things, got on the air in < 10 mins using the Windows app.  I’m running Win 7 Professional x32, and had no difficulties at all (though I did have a false start until I changed to full screen brightness as you suggested).

Anyway, I’ve got an Imp green light flashing at 1/sec now, the blue LED on the Hannah on, as well as the Hannah showing up in the planner … all good stuff.  Looking forward to moving on now.

Many thanks … it’s really appreciated.

Larry


#4

Awesome!! Thanks a lot Rob! I’m running Win 7.


No more Air wood hockey.

Many thanks …

#5

Can you explain “Update Imp Firmware” aside from being the obvious? Does it currently work or will this be a future thing?


#6
Nice one Rob.

Came so close to getting this working on my Mac! Created a wrapper with Wineskin Winery, app seemed to work fine, entered password etc but when it comes time to blink the screen, it crashes.

So close!

Have to wait for the iOS app, in the meantime I can work on my Air wood hockey hi-score!

Bren.

#7

I’m also on Win 7 SP1 x64 so it’s weird you can’t get past the login, jwjames. It could be a certificate issue (https is involved) but I don’t see why XP compatibility mode would fix it.  I’ll keep an eye open.


“Update Firmware” forces an immediate check for more recent firmware. If you’re already on recent firmware you don’t need to do this, I put it in there for people who may be bringing up imps for the first time. Once you have the latest firmware you may even find the Android app starts to work fine for you, with its new half-speed mode (is that released yet Nong?).

The flashing calls into DirectX, but I know there are issues even with a secondary graphics card on a PC, so I’m not entirely surprised it didn’t work with Wine.  Can someone try Parallels or another true virtualisation environment?

Rob


#8

Fantastic!


First attempt was using a Win 7 SP1 install in Parallels on my iMac with no success. The program does not successfully scan for networks so I manually entered the SSID and then the Password, clicked “Connect Imp Using SSID”. After clicking OK on the Prepare to Blink message the program crashes.

Fortunately I have a Windows laptop running Win 7 SP1. After a couple of attempts by Imp is now blinking green!

Thanks!

#9

Worked 1st time, win 7 x64.  A BIG Thank You!!


#10

Same here, worked on Windows 7 Professional SP1 on first attempt. Thank you! 


#11

Worked on the first attempt using an old HP G50 laptop running Windows Vista SP2.


I now have a pretty blinking green April IMP !

Thanks ! 

#12

worked great… thanks.


#13

Thank you, thank you. I have a Droid that didn’t work and no Apple products. This got me started in a couple of minutes (Win 7 starter on an Asus eeePC netbook). Blinking green for go!


#14

Does not work on vmware.


#15

Samsung TV app next :wink:


#16

Yesterday I got my brand new IMP and breakout board from Sparkfun. Put power to it and used the Windows blinkup program on my older Vista Windows with 19inch LCD monitor. Blinkup on the first try! Worked great!

I just wanted to add this post to let people know that the Windows version does work … or it still works, if people are suggesting that it is not working.

I’m just starting out, learning by doing the tutorials. Turned my first LED on and off using a webpage I made … very cool!


#17

I don’t know your computerconfiguration, but for me it doesn’t work.


#18

Dolf, are you in the U.S.? I’ve been seeing on this forum things about WiFi requiring channels 1-11. Is that something common to the U.S.? I’m not sure if that has been a problem for people not in the U.S.

My instructions … what I think is the best way (my opinion), because there seems to be other variations to this.

I discovered that if you power-up the Imp and lay it aside while you enter the SSID and password on the keyboard, the Imp will stop doing things and timeout. It’s important to remove power from the Imp and don’t power it up until you are ready to hit the enter key on the software.

I ran the software and got to the point where it was to enter the last of the password. I didn’t click “go” yet. I just got it ready.

With the Imp on the April board and no power (OFF), I held it between finger and thumb so only the edge with the LED window was showing. I held it about 1 inch from the LCD screen and kept it there.

Now I plugged in the USB cable (to power up the Imp) and typed the last of the password and clicked to Blink-Up. The screen goes black for a second and then the blinking starts. I kept it held until it was done blinking.

This is my opinion, but I think the key is to blink-up SOON after you power-up the Imp and it’s flashing it’s orange, red, “blinking” sequence. Don’t let the Imp go to sleep (or timeout) before the blink-up.

Let me know how that works for you.


#19

my android works fine, so I’ve got no problems.
But a statement that the windows application works, is a bit premature.
It works for you, but this doesn’t mean it works for anyone.
Even a different monitor could make a big difference.
But I am glad it works for you.


#20

Well, it doesn’t work on my MSI netbook running XP SP3 (the program crashes before it even starts blinking). My Android phone got splashed with seawater recently and died, so I reverted to my good old feature phone, which obviously doesn’t run BlinkUp.
While conceptually very simple and elegant, the optical coupling apparently relies on strict timing. I wonder which encoding is used to transfer the relatively short stream of bits. It’s a shame it’s kept secret, since we developers would easily work out a solution using a LED hooked up to a serial port…