BGM113 and imp005 communication

I’m trying communicate via uart0 to a BGM113 bluetooth clip.

Initially, I’m trying just to send a system_hello commnand just to see that I can communicate with the chip.

I’m initiating the uart like this:
bt ← hardware.uart0;
bt.configure(115432, 8, PARITY_NONE, 1, NO_CTSRTS, readback);

and I’m trying to send this:
function hello(){
server.log(“hello”);
local command = format("%c%c%c%c", 0x20, 0x00, 0x01, 0x00);
bt.write(command);
}

(I found the hex code for the system hello command here: https://www.silabs.com/documents/public/reference-manuals/bluetooth-api-reference.pdf)

but the readback function never gets called (so, there is no response from the chip?)

I also tried getting something back by toggling the reset pin (pinN), but still no response.

I tried also using the bglib and chaning what I could change in order to work with the bgm113 but i get an error :
ERROR: ERR: Caught exception while parsing the UART buffer: the index ‘4’ does not exist (line 1129)

What am I missing?

Have you got a logic analyzer? I’d hook up to the pins and actually see if the BGM113 is talking at all.

Also, check you have the correct wiring - TXD on the imp is an output and should be connected to RXD on the BGM113 (and vice versa). Similarly, RTS goes to CTS and vice-versa.