April board failure?

I just got an April board and an Imp to go with it (my second), but I can’t seem to get it to go.

I’ve tried to blink it up several times, with different wifi networks and double checking passwords. It never blinks in any pattern but this slow red:

It does seem to stop the slow red when I attempt to blink it up, but then resumes the same pattern. After about a minute, it stops blinking. It has never shown up in the ide.

MAC address? The first one may have been insufficient power, the second one looks like it’s connecting, being told to go and get an upgrade, but then failing due to a hardware error within the imp.

With the mac address we can look in the logs and see if that is what’s up.

Well, I tried a few other USB ports, direct to desktop and a powered USB 3.0 hub and now I get different behavior: when I plug it in, I get one quick flash of each color, then off, then solid red. This stays on indefinitely:

I checked the ide again and it now has shown up, so it connected at some point… Still doesn’t seem to respond when I try to assign a model to it.

The MAC address is 0c2a6904722b

Yeah, that’s running old software and being told to update. The solid red means the upgrader is unhappy, most likely due to a bad connection within the card.

You should return that imp to your supplier for replacement, I’m afraid.

Awww… Well, thanks for the fast turn-around. :slight_smile: