Any strange agent behavior from this afternoon?

We’ve just rolled in a fairly major backend change, and have had a couple of reports of strange agent behavior.

If you’ve noticed anything unusual - eg, runtime errors, missing device<>agent messages, etc - please email with as much detail as possible (and code).


My imp is not showing up on the planner, and cannot load new code. This happened within the last hour. The imp is connected to wifi (green slow flash the off after 60 sec). Internet is working (I am able to post this). Maybe this has something to do with the change?

i notice weird behavior as well. Same code exaclty on my webforms and agents seems like the get requests get one empty response and one with data. That started after yesterdays migration

So the code is the same on the agents on two different models, the one that had issues yesterday (the agent URL disappeared) seems like it gets 2 get responses, but the one that had no issues works fine. Its like there are 2 devices or an alias with the same agent URL and one responds with correct values, the other one with no values since there is no code to get the values from. But thats what i think i dont know.Hope this helps

It’s working now…

I still continue to see the same issue. Is there anyway i can change the agent URL somehow?

@takissd can you email with more detail (inc mac address of the imp). It sounds like there are two agents running for one of your models.

Starting this morning, my RUN button in the IDE doesn’t work anymore for both my Imps.
So I can’t run new code at the moment, but new code will be saved at the server and the build# is incremented.
Last started code keeps running fine.

I had issues with Run button also. Thought it was related to my code?

I am in this boat now (this morning, worked fine last night). I can’t get new code to run.

I have noticed that agent code does not stop executing when the device’s model is changed. As an example, I have a model in which a device and agent code that interface with But when I change that devices model to a model in which there is NO agent code, the device code updates, but the old model’s agent code continues to run - proven by log output and xively updates.

Auto-correct being a little too helpful in my above post.
Where it says ‘’, it should say ‘’.

ahhh ok that’s most interesting and could be related to the change. Thanks for the report!

@sbright/cnr/dolf - changes to agent code or imp code? It’s working for me right now on my imps.

I can’t change either. I can change the model, though. Not at home to try at the moment, though.

Yesterday I spend some time to register imp (commissioning).
Day later IDE stop react on Run button. Powering imp OFF-ON I get server message “device booting, configuration info” and no more.

Everything is working again for me.

everything back to normal now. For the record: have changed both device- and agentcode.

Seems as if my agent isn’t responding to any http requests…Imp is up and running and the code hasn’t changed. Run button is also not working. Just did another commissioning of the Imp and that hasn’t worked either.

The same problem as kellyg77 have described. Server overload?