Android version of BlinkUp


#1

I’m having a “Devil” of a time (pun intended) getting BlinkUp to work on my two Android devices. Fortunately, my wife’s iOS iPhone works, but this is inconvenient for me in the field when I want to commision new devices. I’m using IMP001 of April boards, all were purchased recently from Digikey.

My Phone: Samsung Galaxy Core LTE SM-G386W running Android 4.4.2.
My Tablet: Samsung Galaxy Tab3 SM-T310 running Android 4.4.2

Legacy mode is not showing up in the Google Play downloaded App? It’s not a setting available anywhere in these Android devices? I’ve tried the darkened room trick, and the blinking up within the first 15 seconds of power up trick. I’ve also already update my IMP001s OS by doing the BlinkUp with my wife’s iPhone, which works perfect the first time in every case. Can I side-load a version of BlinkUp that has the slower blinking rate? If so is there a link to that “more compatible” version of BlinkUp?

Is it just my bad luck, or is BlinkUp support of Android devices lacking somewhat? I read in some older forum postings that a few years ago this was a hot issue and many users were put-off by the support folks at Electric IMP somewhat brushing off what might be a very serious and recurring issue.

There was a Windows version of BlinkUp posted in an old forum posting but it’s now gone. Can this be re-posted please. The entire world does not run exclusively on iOS, and it would be nice to properly support a product on the other popular platforms. Not interested to be flamed in a Windows, versus Apple, Linux/Android debate… I just want equality of BlinkUp support across all platforms… or a good explanation of what this is so difficult?


#2

Further news is that after reading some postings at SparkFun’s website, I followed someone’s advice there, to close all background apps/services on my Android device. I also made myself an ambient light shield by wrapping black electrical tape around the IMP001 sides, allowing only the clear window to be exposed to light. I find now that I have to repeat the BlinkUp “Clear Device Settings” and “Configure a Device” over and over, but eventually it does work from my two Android devices. This is certainly not reliable, fool-proof; and this has been hugely disappointing for me, that such trickery is required. Also, that this vital details are not given in the Step by Step “Getting Started” series on Electric IMP website. I suspect I’m not the only one that’s be stung by this? I read some posting from a few years ago, giving some rather nasty feedback about Android BlinkUp app is “unprofessional”, and “not ready for mass consumption” due to insufficient testing. Here we are years later, and what’s changed? I lost many hours spent trying all sorts of tricks and searching the web for answers, so it has to be expected this can leave a bad taste in people’s mouths!

All I can do is give my case details, and tell how I partially solved my problem, in the hope it helps others. It’s up to the folks at Electric IMP to reconsider if the Android App needs some improvement and/or if the Getting Started guide needs some revision. I hope that reading this helps others…


#3

Resetting the power and performing the BlinkUp within 60 seconds also appears to be needed. So to be very detailed on what works for me, it’s a combination of 4 things:

  • Stop all running apps on Android device using it’s Task Manager.
  • Get the BlinkUp App ready to the last screen before it goes to black and begins the count down.
  • Cycle power to the IMP001, then press next on BlinkUp App right away.
  • Perform a Clear Device’s Settings before attempting the Configure a Device

If I don’t follow all 4 in careful sequence, BlinkUp will usually fail on both my Android devices. Even I follow this procedure perfectly, some other factors going on still make my success rate hit or miss about 50% of the time. Not impressed! :frowning:


#4

So, it’s expected that an imp001 with old firmware will be tricky to blinkup with Android, but after it has connected once and updated its OS you should have a lot less trouble - this is because back in 2013-14 the algorithm was updated to deal with the awful Android frame rate stability, and essentially be self clocking.

All the recently sold kits (e.g. Explorer kit) we update before they’re sold, but the last 001 production run was in 2013 so there’s still plenty of old stock about especially if you buy cards on their own.

Do you still have problems after the firmware update?

We have a test farm of devices and also monitor successful blinkup in the field to make this list: https://electricimp.com/docs/troubleshooting/devices/


#5

We’ve re-instated Legacy Mode in the Android app, a new version of which is currently undergoing QA testing. I can confirm that I can BlinkUp old imp001s using Legacy Mode, but once I have QA’s OK, I’ll get our Android developer to push the new release (4.4.2) out to Google Play.

Should be with you in a day or two, depending on QA approval.


#6

PS. As a check, I re-Blink’d the device using standard BlinkUp mode under Android and that worked fine thanks to the imp001’s updated firmware.