"Agent not running"?

Is there a way to restart an agent through the Web IDE if it tells me “agent not running”?

I can update code on the device but it is frustrating not seeing anything to document why the Agent won’t come back online. Possibly this could be due to rate limiting but in the past this shows up in the device log. Alternatively do I have to use server.restart()?

I should note that clicking “Build and Run” gives me a “Success Your Code is Running” message but the state does not change from “not running”

Thanks Hugo. The Imp with ID: 20000c2a6906cd0b is on a lab bench power supply which I turned off last night after I gave up working on this - it should definitely be back online as of a few minutes ago. I will leave this unit running for the next 128 hours at least. I can also confirm it is connected to the network and pulling data from our servers successfully. I think it’s just the web IDE which is telling me the Agent is not online and not displaying device logs but maybe other things are broken too.

Strangely, when I check the Web IDE dashboard for this imp it reports that the device is always online, even when it is not. Meanwhile the Agent descriptor for this Imp changed from “agent stopped” to “agent not running”.

Anecdotally, we are seeing no problems with agents coming up the first time a unit is blessed and connected to wifi for testing but seem to be having a very difficult time getting agents back online when they have dropped off the network for a month between the factory and the customer’s door.

Ok, I gave up on this electric imp as it was not coming online and switched to a new board I had lying around. Everything worked great for about 15 minutes. Now it tells me "device online / agent stopped " on the new board. Device Logs ceased updating as well.

This all seems oddly similar to this thread: http://forums.electricimp.com/discussion/2184/agent-stopped/p1 - except in my case power cycling the unit does not resolve my issue.

Ok, seems like this is only a problem if one uses an Imp that was previously blessed and then unblessed through the “Remove Global Bond” command. I don’t encounter this issue if I use a device that was never previously bonded/blessed.

All three devices are exactly identical, it just happens that the first two were previously blessed so their agents go offline in the dashboard. The devices appear to be partially accessible in crippled form through the EI command line tools.

The never before blessed imp works perfectly. Now if only we can get less restrictive throttling.

you might check your agent code, because error checking of agent code does only local syntax checking.

@DolfTraanberg it seems like the agent code is ok as it works fine on at least one device.

Did you re-blink up the devices after they had their global bonds removed? That’s likely needed to get them back on the right plan.

What issues are you having with throttling? If you’re answering your requests in a timely fashion, then you shouldn’t be seeing issues - but it’s designed to have multiple people hitting it.

I have the same issue (also did a PM on this). Device has never been blessed beforer. The only thing we did was switch it from one model to another to demonstrate alternative functionality. Unfortunately this is happening in the mids of a customer presentation. Was also not removed, restarted or anything. Just didn’t come up again after changing model

We’re looking into that issue, but it appears to be due to your imp not actually being connected.

I currently have a similar issue. An imp002 prototype that I’m building is running perfectly (server.log() works and I see my sensor values are as expected), but the agent is “not running”.

I get
2015-03-19 13:04:41 UTC+1 [Agent] ERROR: no handler for agent.send()

Not found

When doing HTTP request to a simple http handler returning “OK”/200 to everything.
It has never been blessed - straight from the package.
I tried clearing the configuration using BlinkUp, and re-configuring it. It gets an agent url and everything seems fine. Would rather not desolder the 002 from my breakout board (never really accomplished to do so with any 002) and try another one. Any solution to this? Maybe some hard restart of the agent?


After the recent developer update, I’ve noticed that my agent handler gets recognised, which is great! In the IDE it still says “agent not running”. Imp is in sleep mode most of the time, maybe that’s why?

Got a device ID we can look at?

And still not able to send/receive http request. @Hugo can you somehow restart it?

Again, got a device ID we can look at?

Indeed: 20000c2a690524a6

Seems to be responding to HTTP requests (I just hit this device’s agent and got “OK” back). Are you using the right agent URL?

Strange, I get nothing :confused:

As seen in the picture I’m using https://agent.electricimp.com/ZwSkK-W-NO1l, which was also the url I got when blinking it.

Again I’m currently getting “no handler for agent.send()” when trying to reach it from the device. Worked briefly after an update on the 19th.

There definitely seems to be something wrong on our end - I’ve asked the server team to investigate. Will get back to you.

Lovely, thank you! :slight_smile:

Hey @bobbyziom, could you try the following and let me know if it fixes the problem?

  1. Delete the device from the IDE
  2. Refresh until it shows up in Unassigned Devices (device must be online)
  3. Assign the device to a new model
  4. Assign the device back to the original model you were having trouble with