Agent code not updating


I have an Agent model that was running fine until today. When I try to build and run new revisions of the code, the agent seems to run an older revision of the model.

Has anyone encountered this problem before?


I don’t know if it’s related, by I find that when I make changes to a model (code), that several devices are running, I have to separately “build and run” for each device. Not sure why, seems strange since clicking each device shows the updated code though it’s running the previous rev?

I think there are some quirky things with browser cache and refresh. Try refreshing the browser or leaving and coming back.

Right now some people are seeing issues with the IDE and code versions reverting; can you try using and see whether that works ok for you? Same login etc.

So, if I update model code, and click “Build and Run” when one of the devices attached to that model, should the code be pushed to all devices/agents attached to the model? I tried the beta-ide, and I’m still seeing it only updating the currently selected device/agent.

No. Build & run only updates the one device you have selected.

If you want to build & run multiple devices, the build API will do this on developer devices. Really, deploying to multiple devices is a production feature and goes along with factory process features, security features, blinkup, etc.

I have been having the same issue - the agent code does not seem to be updating anymore. I’ve tried using, refreshing browser cache, and waiting. Appreciate any other suggestions to resolve. Thanks.

Could you give any more details? Device ID, when you tried to update code, whether the device code updates when you press build & run, etc?

Hi Hugo, The device ID is 20000c2a690525a7.

The device code seems to update. I loaded a blank device sketch and that worked on the device.

The logs indicate that the agent code is updated but none of the updates are active. It seems to be stuck on an older version of code. I even tried a totally different model and the agent still seems to be stuck on the previous model. Is there some caching on the agent URL at the server maybe?? (I have tried clearing browser cache and using a different browser on a different platform and still no luck.)

Here are some logs (truncated) when I loaded a totally different agent code with blank device code:
2016-06-06 13:13:31 UTC+10 [Status] Agent restarted: reload.
2016-06-06 13:13:31 UTC+10 [Agent]

2016-06-06 13:16:22 UTC+10 [Status] Downloading new code; 0.45% program storage used

I noticed the issue appearing last night but can’t say when it started (haven’t modified code for a couple of weeks).

Could you file a ticket with ? Is the device blinked up with the electric imp app, not your own one? (if you blinkup a non-blessed device with your production app then strange things happen).

OK. Will do. I suspect I am in the “strange things happen” camp as this is a dev device that has been cycled a few times with various configs. Thanks.

The strange things only happen when you mix production and development… dev devices should be just fine no matter how many models you put them on, etc…

One of my agents reverted to an older version of the code yesterday, while the device correctly used the new version. I could fix it by reverting to the previous build but took awhile to work out why it was failing.

That’s something I wouldn’t expect to see. Got a device ID and an exact timestamp?