After BlinkUp imp connects to WiFi then loses its connection, connects then repeats over and over


#1

I just completed a BlinkUp (I think) as I’m getting four GREEN LED blinks and I see an active DHCP connection on my wireless router. However, after the four GREEN blinks (~10 seconds) I get a RED, RED, AMBER and then back to GREEN for another four. I see the DHCP server resets the expiration time of the IP address each time this occurs so it would appear that it loses the connection and then reassigns it over and over. Any ideas?


#2

Oh, and by the way, I have a laptop right next to the Imp that is connected to the same WiFi network with no problems so I don’t think it’s the wireless router.


#3

Can you post your mac address so we can look in the logs and see what the server isn’t liking about your imp?


#4

It is - 0c:2a:69:04:6e:bc.


#5

Hmm, something a bit strange here. Could you log out of blinkup app, restart it, log in again and blinkup again?


#6

Same issue with mine. I see the ElectricImp (0C 2A 69 04 6D 55 ) in my Wifi router (IP 192.168.1.117 has been assigned to it) , I can even ping it from the router but I get the exact same LED sequence as described (i.e a few Green then Red, Red/Amber, Red/amber and then Green again… ). I checked with WireShark and I see only broadcasts sent either by my router or by the ElectricImp every 10-15 sec


#7

Hi everyone,
I have the same issue with my Electric Imp 001 Dev device (0c2a69001b40) in my network. Blink-up process was done 3 times already.

Any hints ?


#8

I shutdown the blinkup app on my Android phone (Motorola Razor M). I also cleared the application data and caches. I then restarted the blinkup app and re-entered the necessary information and repeated the blinkup process. Same result except the blinking pattern is slightly different. Six long GREENS, 2 seconds of nothing, long RED, short RED, short AMBER then back to six long GREENS. IP expiration resets as before. I even tried setting up another WiFi network with a different router and got the same result. Retried the blinkup process several times as well. -Robert


#9

Same issue with mine - (0c2a690467fe). Retried blinkup process multiple times using both legacy and regular blinkup on a Galaxy S4. Router broadcasts in both 2.4 and 5 GHz, so I gave 5GHz its own SSID and that didn’t work either. Device never shows up in IDE. Any ideas?


#10

I read somewhere there is a potential issue when DNS Relay is activated on the router. My setup is the following : ElectricImp -> WiFi router -> Wired Router -> Internet box and DNS Relay is currently activated on my wired router. I will run some tests tonight and post results


#11

Just logged in again now and the device magically appeared in the IDE - seems go be fixed!


#12

Done ! I disabled DNS Relay, renew all my internal IPs and … device appeared


#13

Yep, this turned out to be an issue with newly created accounts (since mid last week). A token that doesn’t expire was being expired. Sorry this took a while to track down!


#14

@PhilippeLibioulle DNS relay should be fine these days, but if you had a really old imp the firmware may have had problems updating with DNS relay enabled.


#15

I’m now having trouble getting it to blink GREEN. I’ll have to mess with this some more later. I just purchased this Imp so I’m not sure if it’s “old” or not. I’m using a Linksys WRT54G router and I can’t seem to find any configuration item to disable DNS Relay Philippe. Glad to see you have yours running. -Robert


#16

Finally got it working! Thanks.


#17

How did you do it? I have the same router…


#18

@elmanko from your post in the other thread, you have a different problem. In your case, the blinkup is working fine, and the device is connecting fine, but the device managed to leave the budweiser factory without the correct setup due to a factory process issue - which they sorted out with the gen 2 lights (the label doesn’t print unless it passed all the tests).