Firmware update failing, stuck in loop


#21

It’s a standard BT homehub4 (British Telecom, I’m in the UK) providing the wireless access. I’ve got it set to only use 2.5GHz and auto-select channel. It is the same unit I have been using for over 3 years with these two Imps - it moved house with us. I have other wireless points, but can’t get the blinkup to change details to them.


#22

Does it have any landing page? I know the homehubs do have this sometimes especially if parental controls are turned on. This only intercepts port 80 though, so would only affect upgrades.


#23

See this thread here: https://www.amazon.com/gp/help/customer/forums/ref=cs_hc_g_tv?ie=UTF8&forumID=Fx1SKFFP8U1B6N5&cdThread=Tx3I9KSNEGTUWMW

…ensure you have smart setup disabled on the hub, otherwise it will capture the imps attempt to upgrade and prevent this from succeeding. From the thread, it seems like once the device has connected successfully, then you can re-enable it if you want to use that feature.

http://bt.custhelp.com/app/answers/detail/a_id/44328/~/what-is-smart-setup-on-the-bt-hub%3F-how-can-i-turn-it-on-and-off%3F


#24

Hi, there’s no landing page and all of the things like smartsetup and content control are turned off.
I will try again with everything switched off to clear the settings on the imp and get it on a different wifi router. I have another lisa board somewhere too, so will try it in that in case it makes any difference.


#25

Still no luck. When the wifi is off the Imp flashes red as you would expect, then blinkup ends in a green led to suggest it has worked but it still tries to connect to the old network always. Clearing settings or new settings simply do not work. Same results with a different host board.


#26

Are you sure it’s trying to connect to the old network? (as you can’t tell where it’s connecting to from the outside) - solid green means received and I’m not aware of any reports of devices not reliably storing their wifi credentials.

If you clear config, you should see solid green then amber blinking. Do you?

If you send the card to us we’ll send you another, but we’d like to have that one back to try it ourselves.


#27

I’m fairly sure it’s still connecting to the old network because I can see the log messages in the IDE only after I re-enable that wifi point. After trying to clear settings or set another wifi network the log messages don’t appear in the IDE.

On clearing config I see the solid green but then red blinking, which I think is when it tries to connect to wifi.

If you can let me know the correct address then I will get this one posted with a note of return address. Thanks


#28

Hmm, clear config not ending up with flashing amber tends to indicate that there’s some internal hardware issue with the config pages in flash.

email info@electricimp.com and we’ll get you sorted out.